ViewSelector Class
View Selector React component
Extends
- React.Component<ViewSelectorProps, ViewSelectorState>
Methods
Name | Description | |
---|---|---|
constructor(props: ViewSelectorProps): ViewSelector | Creates a ViewSelector | |
componentDidMount(): Promise<void> | ||
componentDidUpdate(prevProps: ViewSelectorProps): Promise<void> | ||
componentWillUnmount(): void | ||
loadViews(): Promise<void> | Query the views and set the initial state with the iModel's views. | |
render(): React.JSX.Element | Renders ViewSelector component | |
updateState(viewId?: any): Promise<void> | Update state of the entries in the widget. | |
updateShowSettings(showSpatials: boolean, showDrawings: boolean, showSheets: boolean, showUnknown: boolean): void Static | Updates the ViewSelector show settings. |
Properties
Name | Type | Description | |
---|---|---|---|
defaultProps Static Readonly | ViewSelectorDefaultProps | ||
onViewSelectorChangedEvent Static Readonly | ViewSelectorChangedEvent | Gets the ViewSelectorChangedEvent. | Deprecated |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.