ToolAssistanceField Class
Tool Assistance Field React component.
@note Tool assistance field will only display 30 characters in the status bar. Any additional text will be hidden. The full text will always be shown in the opened popover.
Extends
- React.Component<ToolAssistanceFieldProps, ToolAssistanceFieldState>
Methods
Name | Description | |
---|---|---|
constructor(p: ToolAssistanceFieldProps): ToolAssistanceField | ||
componentDidMount(): Promise<void> | ||
componentWillUnmount(): void | ||
render(): React.ReactNode |
Properties
Name | Type | Description | |
---|---|---|---|
defaultProps Static Readonly | Pick<ToolAssistanceFieldProps, "includePromptAtCursor" | "uiStateStorage" | "cursorPromptTimeout" | "fadeOutCursorPrompt" | "defaultPromptAtCursor"> |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.