NavigationAidControl Class
Deprecated in 4.16.0. Extends a deprecated class ConfigurableUiControl.
The base class for Navigation Aid controls.
Extends
Extended by
- CubeNavigationAidControl
- DrawingNavigationAidControl
- SheetNavigationAidControl
- StandardRotationNavigationAidControl
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, options: any): NavigationAidControl | ||
getSize(): undefined | string | Square size of navigation aid. | |
getType(): ConfigurableUiControlType | Get the type of this control. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
onFrontstageDeactivated(): void | ConfigurableUiControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void | ConfigurableUiControl | Called when Frontstage is ready. |
onInitialize(): void | ConfigurableUiControl | Called to initialize the ConfigurableUiControl. |
Properties
Name | Type | Description | |
---|---|---|---|
reactNode Accessor | React.ReactNode | The React element associated with this control |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | ConfigurableUiControl | |
applicationData Accessor ReadOnly | any | ConfigurableUiControl | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | ConfigurableUiControl | Gets the class Id of configurable element |
controlId Accessor ReadOnly | string | ConfigurableUiControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor ReadOnly | Promise<void> | ConfigurableUiControl | Returns a promise that resolves when the control is ready for usage. |
name Accessor ReadOnly | string | ConfigurableUiControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.