CursorMenuItemProps Interface

Properties for context menu items.

Extends

Properties

Name Type Description
applicationData any | undefined can be used by application to store miscellaneous data.  
badgeKind BadgeKind | undefined Specifies the kind of badge, if any, to be overlaid on the item.  
badgeType BadgeType | undefined Badge to be overlaid on the item. Deprecated  
description string | StringGetter | ConditionalStringValue if set, it is used to explicitly set the description shown by a component.  
descriptionKey string | undefined if set, it is used to define a key that is used to look up a localized string.  
execute () => any | undefined Function to execute.  
icon IconSpec | undefined Abstract icon definition. Deprecated  
iconNode React.ReactNode | undefined Icon to display.  
iconRight string | ConditionalStringValue Icon to display on right side of the menu item.  
iconSpec IconSpec | undefined Icon to display. Deprecated  
id string The id for the menu item.  
isActive boolean | undefined if set, component will be considered "active" an will display an "active stripe" - defaults to false  
isDisabled boolean | ConditionalBooleanValue if true component will be disabled - defaults to false  
isHidden boolean | ConditionalBooleanValue if true component will be hidden - defaults to false  
isPressed boolean | undefined if set, component will be considered selected but will NOT display an "active stripe" - defaults to false.  
item CommandItemProps | undefined The item to execute when this item is invoked. Deprecated  
label string | StringGetter | ConditionalStringValue if set, it is used to explicitly set the label shown by a component.  
labelKey string | undefined if set, it is used to define a key that is used to look up a localized string.  
submenu CursorMenuItemProps[] | undefined Nested array of item props.  
tooltip string | StringGetter | ConditionalStringValue used to explicitly set the tooltip shown by a component.  
tooltipKey string | undefined if set, it is used to define a key that is used to look up a localized string.  

Inherited properties

Name Type Inherited from Description
className string | undefined CommonProps Custom CSS class name
itemId string | undefined CommonProps Optional unique identifier for item.
style React.CSSProperties | undefined CommonProps Custom CSS style properties

Defined in

Last Updated: 14 November, 2024