UiDataProvidedDialogProps Interface
Deprecated in 4.15.0. Props of deprecated UiDataProvidedDialog component.
Props for UiDataProvidedDialog component.
Properties
Name | Type | Description | |
---|---|---|---|
height | string | number | Initial height of dialog. | |
id | string | undefined | Id used to specify dialog. | |
isModal | boolean | Indicates if Dialog is Modal | |
maxHeight | string | number | Maximum height that the dialog may be resized to. | |
maxWidth | string | number | Maximum width that the dialog may be resized to. | |
minHeight | string | number | Minimum height that the dialog may be resized to. | |
minWidth | string | number | Minimum width that the dialog may be resized to. | |
movable | boolean | undefined | Indicates whether the user can move dialog with cursor. | |
resizable | boolean | undefined | Indicates whether the user can resize dialog with cursor. | |
style | React.CSSProperties | undefined | Custom CSS style properties. | |
title | string | Dialog title | |
uiDataProvider | DialogLayoutDataProvider | Provider that provides and lays out DialogItems | |
width | string | number | Initial width of dialog. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.