DialogLayoutDataProvider Class
DialogLayoutDataProvider Abstract class that allows property values to be passed between hosting API and Dialog that generates and arranges components dynamically including the buttons at the bottom of the dialog.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): DialogLayoutDataProvider | ||
fireDialogButtonsReloadEvent(): void | Called to inform listeners that modal dialog button data needs to be refreshed. | |
supplyButtonData(): undefined | DialogButtonDef[] |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyUiPropertyChange(_updatedValue: DialogPropertySyncItem): void Inherited | UiLayoutDataProvider | Applies change of a single property - this is the default method used when property editors are dynamically generated. |
fireItemsReloadedEvent(): void Inherited | UiLayoutDataProvider | Called to inform listeners that new properties are ready for display in UI. |
fireSyncPropertiesEvent(syncProperties: DialogPropertySyncItem[]): void Inherited | UiLayoutDataProvider | Called to inform listener that the UiDataProvider has updated values for the UI |
loadItemsInternal(items: ReadonlyArray<DialogItem>): void Protected Inherited | UiLayoutDataProvider | |
processChangesInUi(properties: DialogPropertyItem[]): PropertyChangeResult Inherited | UiLayoutDataProvider | Applies changes from one or more properties - some dialogs will use this to send a bulk set of changes back to the provider |
reloadDialogItems(emitEvent: booleantrue): void Inherited | UiLayoutDataProvider | Called to inform listeners that new properties are ready for display in UI. |
supplyAvailableProperties(): DialogPropertyItem[] Inherited | UiLayoutDataProvider | Used to pass properties between a tool and an explicity defined UI dialog. |
supplyDialogItems(): undefined | DialogItem[] Inherited | UiLayoutDataProvider | Called by UI to request available properties that can be bound to user supplied UI components (See Tool1UiProvider for example). |
syncProperties(syncProperties: DialogPropertySyncItem[]): void Inherited | UiLayoutDataProvider | Called to sync properties synchronously if a UiDataProvider is active for the UI |
validateProperty(_item: DialogPropertyItem): PropertyChangeResult Inherited | UiLayoutDataProvider | Called by UI to validate a property value |
editorWantsLabel(item: DialogItem): boolean Static Inherited | UiLayoutDataProvider | Determines if a dialog item editor wants a label |
getItemDisabledState(baseDialogItem: BaseDialogItem): boolean Static Inherited | UiLayoutDataProvider | Gets the disabled state for a given dialog item |
getPropertyRecord(dialogItem: BaseDialogItem): PropertyRecord Static Inherited | UiLayoutDataProvider | Gets a property record for a given dialog item |
hasAssociatedLockProperty(item: DialogItem): boolean Static Inherited | UiLayoutDataProvider | Determines if a dialog items has an associated lock property |
onlyContainButtonGroupEditors(row: DialogRow): boolean Static Inherited | UiLayoutDataProvider | Determines if a dialog row only contains button group editors |
Properties
Name | Type | Description | |
---|---|---|---|
onButtonsReloadedEvent | BeUiEvent<void> |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
items Accessor Inherited ReadOnly | ReadonlyArray<DialogItem> | UiLayoutDataProvider | |
onItemsReloadedEvent Inherited | BeUiEvent<void> | UiLayoutDataProvider | |
onSyncPropertiesChangeEvent Inherited | SyncPropertiesChangeEvent | UiLayoutDataProvider | Get Sync UI Control Properties Event |
rows Accessor Inherited ReadOnly | DialogRow[] | UiLayoutDataProvider | Array of dialog rows |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.