CursorPopupManager Class
CursorPopup component
Methods
Name | Description | |
---|---|---|
constructor(): CursorPopupManager | ||
close(id: string, apply: boolean, fadeOut?: boolean): void Static | Called when tool wants to close the popup | |
open(id: string, content: React.ReactNode, pt: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, relativePosition: RelativePosition, priority: number0, options?: CursorPopupOptions): void Static | Called to open popup with a new set of properties | |
update(id: string, content: React.ReactNode, pt: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, relativePosition: RelativePosition, priority: number0): void Static | Called to update popup with a new set of properties | |
updatePosition(pt: Readonly<WritableXAndY>): void Static | Called to move the open popup to new location |
Properties
Name | Type | Description | |
---|---|---|---|
popupCount Accessor Static ReadOnly | number | ||
popups Accessor Static ReadOnly | CursorPopupInfo[] |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.