ViewportContentControl Class
Deprecated in 4.16.0. Extends a deprecated class ContentControl.
The base class for frontstage Viewport content controls that connects to a ScreenViewport
that is managed by the ViewManager
.
Extends
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(info: ConfigurableCreateInfo, options: any): ViewportContentControl | Creates an instance of ViewportContentControl. | |
getReactElementForViewSelectorChange(_iModel: IModelConnection, _viewDefinitionId: string, _viewState: ViewState, _name: string): React.ReactNode | Get the React.Element for a ViewSelector change. | |
getType(): ConfigurableUiControlType | Gets the type of ConfigurableUiControl, which is 'Viewport' in this case | |
onActivated(): void | Called when this ContentControl is activated | |
processViewSelectorChange(iModel: IModelConnection, viewDefinitionId: string, viewState: ViewState, name: string): Promise<void> | Process a ViewSelector change. | |
setIsReady(): void | Returns a promise that resolves when the control is ready for usage. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getKeyedReactNode(): React.ReactNode Protected | ContentControl | |
getReactNode(): React.ReactNode Protected | ContentControl | |
onDeactivated(): void | ContentControl | Called when this ContentControl is deactivated |
onFrontstageDeactivated(): void | ContentControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void | ContentControl | Called when Frontstage is ready. |
onInitialize(): void | ContentControl | Called to initialize the ConfigurableUiControl. |
Properties
Name | Type | Description | |
---|---|---|---|
isReady Accessor ReadOnly | Promise<void> | Returns a promise that resolves when the control is ready for usage. | |
isViewport Accessor ReadOnly | boolean | Returns true if this control is a Viewport control. | |
navigationAidControl Accessor ReadOnly | string | Get the NavigationAidControl associated with this ContentControl | |
supportsViewSelectorChange Accessor ReadOnly | boolean | Returns true if this control supports processing ViewSelector changes. | |
viewport Accessor | undefined | ScreenViewport | The underlying ScreenViewport |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected | any | ContentControl | |
_reactNode Protected | React.ReactNode | ContentControl | |
applicationData Accessor ReadOnly | any | ContentControl | allow options set via appData to be seen by API calls |
classId Accessor ReadOnly | string | ContentControl | Gets the class Id of configurable element |
controlId Accessor ReadOnly | string | ContentControl | Returns the ID of this ConfigurableUiControl. |
name Accessor ReadOnly | string | ContentControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
reactNode Accessor | React.ReactNode | ContentControl | The React node associated with this control. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.