FloatingContentControl Class
Deprecated in 4.16.0. Use UiItemsProvider to provide a floating Widget instead.
Additionally, use ContentOverlay component to display the active content indicator.
Extends
Methods
Name | Description | |
---|---|---|
constructor(uniqueId: string, name: string, node: React.ReactNode): FloatingContentControl |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getKeyedReactNode(): React.ReactNode Protected Inherited | ContentControl | |
getReactNode(): React.ReactNode Protected Inherited | ContentControl | |
getType(): ConfigurableUiControlType Inherited | ContentControl | Gets the type of ConfigurableUiControl, which is 'Content' in this case |
onActivated(): void Inherited | ContentControl | Called when this ContentControl is activated |
onDeactivated(): void Inherited | ContentControl | Called when this ContentControl is deactivated |
onFrontstageDeactivated(): void Inherited | ContentControl | Called when Frontstage is deactivated. |
onFrontstageReady(): void Inherited | ContentControl | Called when Frontstage is ready. |
onInitialize(): void Inherited | ContentControl | Called to initialize the ConfigurableUiControl. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_appDataOptions Protected Inherited | any | ContentControl | |
_reactNode Protected Inherited | React.ReactNode | ContentControl | |
applicationData Accessor Inherited ReadOnly | any | ContentControl | allow options set via appData to be seen by API calls |
classId Accessor Inherited ReadOnly | string | ContentControl | Gets the class Id of configurable element |
controlId Accessor Inherited ReadOnly | string | ContentControl | Returns the ID of this ConfigurableUiControl. |
isReady Accessor Inherited ReadOnly | Promise<void> | ContentControl | Returns a promise that resolves when the control is ready for usage. |
isViewport Accessor Inherited ReadOnly | boolean | ContentControl | Returns true if this control is a Viewport control. |
name Accessor Inherited ReadOnly | string | ContentControl | Get internal name of configurable element. If no name is defined in configuration then the name will match the UniqueId. |
navigationAidControl Accessor Inherited ReadOnly | string | ContentControl | Get the NavigationAidControl associated with this ContentControl |
reactNode Accessor Inherited | React.ReactNode | ContentControl | The React node associated with this control. |
viewport Accessor Inherited ReadOnly | undefined | ScreenViewport | ContentControl | Returns the ScreenViewport if isViewport is true |
Defined in
Last Updated: 14 March, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.