showMenuButton Method
Deprecated in 4.11.0. Please use showMenuButton.
Show a menu button at a particular location. A menu button opens a context menu.
showMenuButton(id: string, menuItemsProps: AbstractMenuItemProps[], location: Readonly<WritableXAndY>, htmlElement?: HTMLElement): boolean
@returns true if the menu was displayed, false if the menu could not be displayed.
Parameter | Type | Description |
---|---|---|
id | string | Id of the menu button. Multiple menu buttons may be displayed. |
menuItemsProps | AbstractMenuItemProps[] | Properties of the menu items to display. |
location | Readonly<WritableXAndY> | Location of the context menu, relative to the origin of htmlElement or the window. |
htmlElement | HTMLElement | The HTMLElement that anchors the context menu. If undefined, the location is relative to the overall window. |
Returns - boolean
true if the menu was displayed, false if the menu could not be displayed.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.