showContextMenu Method
Deprecated in 4.11.0. Use openContextMenu
Show a context menu at a particular location.
showContextMenu(items: AbstractMenuItemProps[], location: Readonly<WritableXAndY>, htmlElement?: HTMLElement): boolean
@returns true if the menu was displayed, false if the menu could not be displayed.
Parameter | Type | Description |
---|---|---|
items | AbstractMenuItemProps[] | Properties of the menu items to display. |
location | Readonly<WritableXAndY> | Location of the context menu, relative to the origin of htmlElement or the overall window. |
htmlElement | HTMLElement | The HTMLElement that anchors the context menu. If undefined, the location is relative to the overall window. |
Returns - boolean
true if the menu was displayed, false if the menu could not be displayed.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.