openToolSettingsPopup Method
Opens a Tool Settings Ui popup at a particular location.
openToolSettingsPopup(dataProvider: DialogLayoutDataProvider, location: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onCancel: OnCancelFunc, relativePosition?: RelativePosition, anchorElement?: HTMLElement): boolean
@returns true if the tool settings were displayed, false if the tool settings could not be displayed.
Parameter | Type | Description |
---|---|---|
dataProvider | DialogLayoutDataProvider | The DialogLayoutDataProvider for the tool settings popup dialog. |
location | Readonly<WritableXAndY> | Location of the tool settings, relative to the origin of anchorElement or the window |
offset | Readonly<WritableXAndY> | Offset of the tool settings from the location |
onCancel | OnCancelFunc | Function invoked when the Escape key is pressed or a click occurs outside the tool settings |
relativePosition | RelativePosition | Position relative to the given location. Defaults to TopRight. |
anchorElement | HTMLElement | The HTMLElement that anchors the tool settings. If undefined, the location is relative to the overall window. |
Returns - boolean
true if the tool settings were displayed, false if the tool settings could not be displayed.
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.