IconSpecUtilities Class
Deprecated in 4.3. AppUI libraries >= 4.7.x support loading SVGs sources without prefixes, eliminating the need for these utilities.
Creates an IconSpec with an SVG source and gets the SVG source from an IconSpec.
Methods
Name | Description | |
---|---|---|
constructor(): IconSpecUtilities | ||
createSvgIconSpec(svgSrc: string): string Static | Create an IconSpec for an SVG loaded into web component with sprite loader | Deprecated |
createWebComponentIconSpec(srcString: string): string Static | Create an IconSpec for an SVG loaded into web component with svg-loader | Deprecated |
getSvgSource(iconSpec: string): undefined | string Static | Get the SVG Source from an sprite IconSpec | Deprecated |
getWebComponentSource(iconSpec: string): undefined | string Static | Get the SVG Source from an svg-loader IconSpec | Deprecated |
Properties
Name | Type | Description | |
---|---|---|---|
SVG_PREFIX Static Readonly | "svg:" | Prefix for an SVG IconSpec loaded with the Sprite loader | |
WEB_COMPONENT_PREFIX Static Readonly | "webSvg:" |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.