AbstractStatusBarCustomItem Interface
Deprecated in 3.6. Use StatusBarCustomItem instead.
Describes the data needed to insert a custom item into the status bar. This is used to allow extension implementer to create a framework specific component.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
isCustom Readonly | "true" |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData Inherited | any | undefined | AbstractStatusBarItem | can be used by application to store miscellaneous data. |
badgeType Readonly Inherited | BadgeType | undefined | AbstractStatusBarItem | Describes badge. |
id Readonly Inherited | string | AbstractStatusBarItem | Required unique id of the item. |
internalData Readonly Inherited | Map<string, any> | undefined | AbstractStatusBarItem | optional data to used by item implementor. |
isDisabled Readonly Inherited | boolean | ConditionalBooleanValue | AbstractStatusBarItem | Describes if the item is enabled or disabled. |
isHidden Readonly Inherited | boolean | ConditionalBooleanValue | AbstractStatusBarItem | Describes if the item is visible or hidden. |
itemPriority Readonly Inherited | number | AbstractStatusBarItem | Priority within a section (recommend using values 1 through 100). |
providerId Readonly Inherited | string | undefined | AbstractStatusBarItem | id of UiItemsProvider |
section Readonly Inherited | StatusBarSection | AbstractStatusBarItem | status bar section |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.