BackstageActionItem Interface

Deprecated  in 3.6. Use BackstageActionItem instead.

Describes the data needed to insert an action button into the backstage menu.

Extends

Properties

Name Type Description
execute Readonly () => void    

Inherited properties

Name Type Inherited from Description
applicationData Inherited any | undefined CommonBackstageItem can be used by application to store miscellaneous data.
badgeType Readonly Inherited BadgeType | undefined CommonBackstageItem Describes badge.
groupPriority Readonly Inherited number CommonBackstageItem Specifies the item's grouping value.
icon Readonly Inherited string | ConditionalStringValue CommonBackstageItem Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id.
id Readonly Inherited string CommonBackstageItem Required unique id of the item.
internalData Readonly Inherited Map<string, any> | undefined CommonBackstageItem optional data to be used by item implementor.
isActive Readonly Inherited boolean | ConditionalBooleanValue CommonBackstageItem Describes if the item is active.
isDisabled Readonly Inherited boolean | ConditionalBooleanValue CommonBackstageItem Describes if the item is enabled or disabled.
isHidden Readonly Inherited boolean | ConditionalBooleanValue CommonBackstageItem Describes if the item is visible or hidden.
itemPriority Readonly Inherited number CommonBackstageItem Priority within a group (recommend using values 1 through 100).
label Readonly Inherited string | ConditionalStringValue CommonBackstageItem Label.
providerId Readonly Inherited string | undefined CommonBackstageItem id of UiItemsProvider
subtitle Readonly Inherited string | ConditionalStringValue CommonBackstageItem Subtitle.
tooltip Readonly Inherited string | ConditionalStringValue CommonBackstageItem Tooltip.

Defined in

Last Updated: 14 November, 2024