appui-abstract
Classes
Name | Description | |
---|---|---|
AbstractStatusBarItemUtilities | Helper class to create Abstract StatusBar Item definitions. | Deprecated |
BackstageItemUtilities | Utilities for creating and maintaining backstage items | Deprecated |
BaseQuantityDescription | Base Quantity Property Description | Beta |
BaseUiItemsProvider | Base implementation of a UiItemsProvider. | Deprecated |
ConditionalBooleanValue | Class used to return a boolean value. | |
ConditionalStringValue | Class used to return a string value. | |
DialogLayoutDataProvider | DialogLayoutDataProvider Abstract class that allows property values to be passed between hosting API and Dialog that generates and arranges components dynamically | |
DialogProperty | DialogProperty is a generic helper class that assists working with properties used by UiLayoutDataProvider implementations (i.e. | |
GenericUiEvent | The GenericUiEvent is the base event class for UI events that target a specific component, as identified in uiComponentId. | |
IconSpecUtilities | Creates an IconSpec with an SVG source and gets the SVG source from an IconSpec. | |
PropertyDescriptionHelper | Helper class that builds property descriptions for specific PropertyEditors and processes descriptions. | |
PropertyRecord | PropertyRecord contains instance information about a Property, including a | |
StandardContentLayouts | Class that define Standard Content Layouts that can be used to specify how the content is arranged in a frontstage. | |
SyncPropertiesChangeEvent | Sync UI Control Properties Event class. | |
ToolbarItemUtilities | Helper class to create Abstract StatusBar Item definitions. | |
UiAdmin | The UiAdmin controls various UI components and is callable from IModelApp.uiAdmin in the core-frontend package. | |
UiDataProvider | UiDataProvider Abstract class that allows property values to be passed between hosting API and UI. | |
UiError | iTwin.js UI UiError class is a subclass of BentleyError. | |
UiEvent | iTwin.js UI UiEvent class is a subclass of BeEvent with argument type safety. | |
UiEventDispatcher | This class is used to send eventIds to interested UI components so the component can determine if it needs | |
UiItemsManager | Controls registering of UiItemsProviders and calls the provider's methods when populating different parts of the User Interface. | Deprecated |
UiLayoutDataProvider | ||
UiSyncEvent | UiSync Event class. |
Enumerations
Name | Description | |
---|---|---|
AbstractZoneLocation | Enum for AppUi 1 Zone locations that can have widgets added to them at run-time via UiItemsProvider. |
|
AlternateDateFormats | Alternate Data Formats that can be provide by javascript. | |
BackstageItemType | Used to specify the item type added to the backstage menu. | Deprecated |
BadgeType | Specifies type of badge, if any, that should be overlaid on UI component. | |
DialogButtonStyle | Enum for button style. | |
DialogButtonType | Enum for button types. | |
Describes the type and behavior of a display message. | ||
FunctionKey | Enumeration for Function Keys | |
Message Severity enum for display messages. | ||
PropertyChangeStatus | Status of Proposed property changes from UI to UiDataProvider | |
PropertyEditorParamTypes | Enum for Property Editor Param Types | |
PropertyValueFormat | Enumeration for Format of the property value. | |
RelativePosition | Relative Position for popups | |
SpecialKey | Enumeration for Special Keys | |
StagePanelLocation | Available Stage Panel locations. | Deprecated |
StagePanelSection | Enum for Stage Panel Sections | Deprecated |
StageUsage | Standard stage uses. | Deprecated |
StandardEditorNames | Standard Editor Names for property editors. | |
StandardTypeNames | Standard Type Names for converters and editors. | |
StatusBarLabelSide | Defines which side of Icon where label is placed | Deprecated |
StatusBarSection | Status bar Groups/Sections from Left to Right | Deprecated |
TimeDisplay | Enum that defines supported time formats. | |
ToolbarOrientation | Used to specify the orientation of the toolbar. | Deprecated |
ToolbarUsage | Used to specify the usage of the toolbar which determine the toolbar position. | Deprecated |
UiItemsApplicationAction | Action taken by the application on item provided by a UiItemsProvider | |
WidgetState | Widget state enum. | Deprecated |
Global Functions
Name | Description | |
---|---|---|
isAbstractStatusBarActionItem | AbstractStatusBarActionItem type guard. | Deprecated |
isAbstractStatusBarCustomItem | AbstractStatusBarCustomItem type guard. | Deprecated |
isAbstractStatusBarLabelItem | AbstractStatusBarLabelItem type guard. | Deprecated |
isActionItem | BackstageActionItem type guard. | Deprecated |
isArrowKey | Determines if a KeyboardEvent.key is an Arrow key | |
isButtonGroupEditorParams | ButtonGroupEditorParams type guard. | |
isColorEditorParams | ColorEditorParams type guard. | |
isCustomFormattedNumberParams | CustomFormattedNumberParams type guard. | |
isIconListEditorParams | IconListEditorParams type guard. | |
isInputEditorSizeParams | InputEditorSizeParams type guard. | |
isStageLauncher | BackstageStageLauncher type guard. | Deprecated |
isSuppressLabelEditorParams | SuppressLabelEditorParams type guard. |
Interfaces
Name | Description | |
---|---|---|
AbstractActionItemProps | Definition for an item that executes and action. | |
AbstractMenuItemProps | Properties for a Menu item | |
AbstractStatusBarActionItem | Describes the data needed to insert an action item into the status bar. | Deprecated |
AbstractStatusBarCustomItem | Describes the data needed to insert a custom item into the status bar. | Deprecated |
AbstractStatusBarItem | Describes the data needed to insert a button into the status bar. | Deprecated |
AbstractStatusBarLabelItem | Describes the data needed to insert a label item with an optional icon into the status bar. | Deprecated |
AbstractToolbarProps | Definition for a Toolbar. | |
AbstractWidgetProps | Properties for a Widget. | Deprecated |
ActionButton | Describes the data needed to insert an action button into a toolbar. | |
AllowedUiItemProviderOverrides | UiItemProviderOverrides allows the application that registers a provider to limit when it is allowed to provide items | Deprecated |
ArrayValue | Array property value | |
BackstageActionItem | Describes the data needed to insert an action button into the backstage menu. | Deprecated |
BackstageStageLauncher | Describes the data needed to insert an action button into the backstage menu. | Deprecated |
BaseDialogItem | BaseDialogItem contains only the members necessary to create a PropertyRecord. | |
BasePropertyEditorParams | BasePropertyEditorParams Base interface for Property Editor Params | |
BasePropertyValue | Base interface for a property value | |
ButtonGroupEditorParams | ButtonGroupEditorParams Parameters used by EnumButtonGroupEditor to define icons in button group. | |
ColorEditorParams | ColorEditorParams Parameters used to populate color type editor with a specific set of colors. | |
CommandHandler | Definition for a command handler. | |
CommonBackstageItem | Describes the data needed to insert a button into the backstage menu. | Deprecated |
CommonItemProps | Definition that specifies properties shared between many ConfigurableUi components. | |
ContentLayoutProps | Properties for a ContentLayoutDef | |
CustomButtonDefinition | Describes the data needed to insert a custom button into a toolbar. | |
CustomFormattedNumberParams | Parameters used with properties that want to control parsing and formatting. | |
DateFormatter | Interface used to provide a custom Date Time formatter and optional parser | |
DialogButtonDef | Interface for a dialog button in a button cluster | |
DialogItem | DialogItem is the specification that the display engine turns into a UI item. | |
DialogItemValue | DialogItemValue Interface of PrimitiveValue types that have type editor support for use in dialogs. | |
DialogPropertyItem | DialogPropertyItem us the specification to use if you are defining the components directly, e.g., in React | |
DialogPropertySyncItem | DialogPropertySyncItem is used to pass sync messages for DialogPropertyItems | |
DialogProps | Optional props to pass to the Dialog control that is generated. | |
DialogRow | DialogRow is the interface that groups dialog items into rows for building UI | |
EditorPosition | EditorPosition Interface used to identify the location of the item a DialogItem property value. | |
EnumerationChoice | Information about an enumeration choice | |
EnumerationChoicesInfo | Information about a set of enumeration choices | |
GenericUiEventArgs | The Generic UI Event args contains information useful for any UI message | |
GroupButton | Describes the data needed to insert a group button into a toolbar. | |
IconDefinition | IconDefinition Information about an icon displayed next to a property editor. | |
IconEditorParams | Parameters used to display an icon next to property editor. | |
IconListEditorParams | IconListEditorParams Parameters used to populate icon type editor with a specific set of icons. | |
ImageCheckBoxParams | Parameters for ImageCheckBoxEditor | |
IMatch | Interface that returns indices of matches | |
InputEditorSizeParams | InputEditorSizeParams type guard. | |
LayoutFragmentProps | Properties for a layout fragment | |
LayoutHorizontalSplitProps | Properties for a horizontal layout split | |
LayoutSplitPropsBase | Base interface for layout split properties | |
LayoutVerticalSplitProps | Properties for a vertical layout split. | |
LinkElementsInfo | Properties for the PropertyRecord with link info supplied | |
MessagePresenter interface functions display messages. | ||
MultilineTextEditorParams | Parameter that is used to indicate that a multiline text editor should be created. | |
ParseResults | defines Results of parsing a string input by a user into its desired value type | |
PointProps | Describes 2d points. | |
PrimitiveValue | Primitive property value | |
PropertyChangeResult | Interface used by UiDataProvider to report change status (validation) to UI. | |
PropertyConverterInfo | Information about a Property Converter | |
PropertyDescription | PropertyDescription contains metadata about a Property | |
PropertyEditorInfo | Information about a Property Editor | |
PropertyRendererInfo | Property renderer identification and customization attributes | |
ProvidedItem | Properties for an item provided by UiItemsProvider | Deprecated |
RangeEditorParams | Parameters used by PropertyEditors that support defining a minimum and maximum value. | |
SliderEditorParams | Parameters used to indicate that a Slider should be presented for the property | |
StructValue | Struct property value | |
SuppressLabelEditorParams | SuppressLabelEditorParams Parameters used to suppress the label for a type editor in the ToolSettings widget. | |
SyncPropertiesChangeEventArgs | Sync UI Control Properties Event Args interface. | |
ToolbarItem | Describes the data needed to insert a UI items into an existing set of UI items. | |
UiFlags | Flags that control enabling/disabling certain UI features | |
UiItemProviderRegisteredEventArgs | UIProvider Registered Event Args interface. | Deprecated |
UiItemsProvider | Describes interface of objects that want to provide UI component to the running IModelApp. | Deprecated |
UiSyncEventArgs | UiSync Event arguments. |
Namespaces
Name | Description | |
---|---|---|
Primitives | Primitive Property Value Types. |
Type Aliases
Name | Description | |
---|---|---|
BackstageItem | Describes the data needed to insert a button into the backstage menu. | Deprecated |
CommonStatusBarItem | Describes the data needed to insert a button into the status bar. | Deprecated |
CommonToolbarItem | Any Button Type that can be inserted into a toolbar. | |
OnCancelFunc | ||
OnItemExecutedFunc | ||
OnNumberCommitFunc | ||
OnValueCommitFunc | ||
PropertyEditorParams | Type definition for Property Editor params | |
PropertyValue | Type for all property values | |
StatusBarItemId | Type for StatusBar Item Id | Deprecated |
StringGetter | ||
ToolbarItemId | Type for Toolbar Item Id | Deprecated |
UiItemProviderOverrides | Allowed overrides applied to a UiItemsProvider the application that registers a provider to limit when it is allowed to provide items. | Deprecated |
Last Updated: 20 June, 2023