UiLayoutDataProvider Class
Extends
Extended by
Methods
Name |
Description |
|
constructor(): UiLayoutDataProvider |
|
|
applyUiPropertyChange(_updatedValue: DialogPropertySyncItem): void |
Applies change of a single property - this is the default method used when property editors are dynamically generated. |
|
loadItemsInternal(items: undefined | ): void Protected |
|
|
processChangesInUi(properties: DialogPropertyItem[]): PropertyChangeResult |
Applies changes from one or more properties - some dialogs will use this to send a bulk set of changes back to the provider |
|
reloadDialogItems(emitEvent: boolean = true): void |
Called to inform listeners that new properties are ready for display in UI. |
|
supplyDialogItems(): undefined | DialogItem[] |
Called by UI to request available properties that can be bound to user supplied UI components (See Tool1UiProvider for example). |
|
editorWantsLabel(item: DialogItem): boolean Static |
Determines if a dialog item editor wants a label |
|
getItemDisabledState(baseDialogItem: BaseDialogItem): boolean Static |
Gets the disabled state for a given dialog item |
|
getPropertyRecord(dialogItem: BaseDialogItem): PropertyRecord Static |
Gets a property record for a given dialog item |
|
hasAssociatedLockProperty(item: DialogItem): boolean Static |
Determines if a dialog items has an associated lock property |
|
onlyContainButtonGroupEditors(row: DialogRow): boolean Static |
Determines if a dialog row only contains button group editors |
|
Inherited methods
Properties
Name |
Type |
Description |
|
items Accessor ReadOnly |
undefined |
|
|
rows Accessor ReadOnly |
DialogRow[] |
Array of dialog rows |
|
Inherited properties
Defined in
Last Updated:
20 June, 2023