GroupButton Interface
Describes the data needed to insert a group button into a toolbar.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
icon Readonly | string | ConditionalStringValue | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. | |
items Readonly | undefined | children of the group | |
label Readonly | string | ConditionalStringValue | label, shown as tool tip on group button or a group button label in a group panel. | |
panelLabel Readonly | string | ConditionalStringValue | label shown as the title in at top of group panel. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData Readonly | undefined | any | ToolbarItem | can be used by application to store miscellaneous data. |
badgeType Readonly | undefined | BadgeType | ToolbarItem | Describes badge. |
description Readonly | string | ConditionalStringValue | ToolbarItem | Optional description |
groupPriority Readonly | undefined | number | ToolbarItem | Specifies the item's grouping value. |
id Readonly | string | ToolbarItem | Require uniqueId for the item. |
internalData Readonly | undefined | Map<string, any> | ToolbarItem | optional data to used by item implementor. |
isActive Readonly | undefined | boolean | ToolbarItem | Defines if the item is active (shown with an active stripe/bar). |
isDisabled Readonly | boolean | ConditionalBooleanValue | ToolbarItem | Describes if the item is enabled or disabled. |
isHidden Readonly | boolean | ConditionalBooleanValue | ToolbarItem | Describes if the item is visible or hidden. |
isPressed Readonly | undefined | boolean | ToolbarItem | Describes if the item should appear pressed (used for displaying toggle state). |
itemPriority Readonly | number | ToolbarItem | Priority within a toolbar or group. |
parentToolGroupId Readonly | undefined | string | ToolbarItem | Optional parent tool group to add tool. |
providerId Readonly | undefined | string | ToolbarItem | id of UiItemsProvider |
Defined in
Last Updated: 20 June, 2023