ToolbarItem Interface
Describes the data needed to insert a UI items into an existing set of UI items.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applicationData Readonly | undefined | any | can be used by application to store miscellaneous data. | |
badgeType Readonly | undefined | BadgeType | Describes badge. | |
description Readonly | string | ConditionalStringValue | Optional description | |
groupPriority Readonly | undefined | number | Specifies the item's grouping value. | |
id Readonly | string | Require uniqueId for the item. | |
internalData Readonly | undefined | Map<string, any> | optional data to used by item implementor. | |
isActive Readonly | undefined | boolean | Defines if the item is active (shown with an active stripe/bar). | |
isDisabled Readonly | boolean | ConditionalBooleanValue | Describes if the item is enabled or disabled. | |
isHidden Readonly | boolean | ConditionalBooleanValue | Describes if the item is visible or hidden. | |
isPressed Readonly | undefined | boolean | Describes if the item should appear pressed (used for displaying toggle state). | |
itemPriority Readonly | number | Priority within a toolbar or group. | |
parentToolGroupId Readonly | undefined | string | Optional parent tool group to add tool. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
providerId Readonly | undefined | string | ProvidedItem | id of UiItemsProvider |
Defined in
Last Updated: 20 June, 2023