IconSpecUtilities Class
Creates an IconSpec with an SVG source and gets the SVG source from an IconSpec.
Methods
Name | Description | |
---|---|---|
constructor(): IconSpecUtilities | ||
createSvgIconSpec(svgSrc: string): string Static | Create an IconSpec for an SVG loaded into web component with sprite loader | |
createWebComponentIconSpec(srcString: string): string Static | Create an IconSpec for an SVG loaded into web component with svg-loader | |
getSvgSource(iconSpec: string): undefined | string Static | Get the SVG Source from an sprite IconSpec | |
getWebComponentSource(iconSpec: string): undefined | string Static | Get the SVG Source from an svg-loader IconSpec |
Properties
Name | Type | Description | |
---|---|---|---|
SVG_PREFIX StaticReadonly | "svg:" | Prefix for an SVG IconSpec loaded with the Sprite loader | |
WEB_COMPONENT_PREFIX StaticReadonly | "webSvg:" |
Defined in
Last Updated: 20 June, 2023