LayoutVerticalSplitProps Interface
Properties for a vertical layout split. When a member is a LayoutFragmentProps, it creates a nested split pane. When a number, it represents an index into a ContentGroup.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
left | number | LayoutFragmentProps | Left layout fragment properties. | |
minSizeLeft | undefined | number | Minimum size of the left fragment. | |
minSizeRight | undefined | number | Minimum size of the right fragment. | |
right | number | LayoutFragmentProps | Right layout fragment properties. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
id | string | LayoutSplitPropsBase | The id used to save the current state of the splitter |
lock | undefined | boolean | LayoutSplitPropsBase | Used to lock splitter into fixed position. |
percentage | number | LayoutSplitPropsBase | The percentage of this layout that should be occupied by the top/left fragment by default |
Defined in
Last Updated: 20 June, 2023