AbstractMenuItemProps Interface
Properties for a Menu item
Extends
Properties
Name | Type | Description | |
---|---|---|---|
iconRight | string | ConditionalStringValue | Icon to display on right side of the menu item. | |
id | string | The id for the menu item. | |
item | undefined | AbstractActionItemProps | The item to execute when this item is invoked. | |
submenu | undefined | AbstractMenuItemProps[] | Nested array of item props. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | undefined | any | CommonItemProps | can be used by application to store miscellaneous data. |
badgeType | undefined | BadgeType | CommonItemProps | Badge to be overlaid on the item. |
description | string | ConditionalStringValue | CommonItemProps | if set, it is used to explicitly set the description shown by components that support a description. |
icon | string | ConditionalStringValue | CommonItemProps | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. |
internalData Readonly | undefined | Map<string, any> | CommonItemProps | optional data to be used by item implementor. |
isActive | undefined | boolean | CommonItemProps | if set, component will be considered "active" an will display an "active stripe" - defaults to false |
isDisabled | boolean | ConditionalBooleanValue | CommonItemProps | if true component will be disabled - defaults to false |
isHidden | boolean | ConditionalBooleanValue | CommonItemProps | if true component will be hidden - defaults to false |
isPressed | undefined | boolean | CommonItemProps | if set, component will be considered selected but will NOT display an "active stripe" - defaults to false. |
label | string | ConditionalStringValue | CommonItemProps | if set, it is used to explicitly set the label shown by a component. |
tooltip | string | ConditionalStringValue | CommonItemProps | used to explicitly set the tooltip shown by a component. |
Defined in
Last Updated: 20 June, 2023