BaseUiItemsProvider Class
Deprecated in 3.6. Use BaseUiItemsProvider instead.
Base implementation of a UiItemsProvider. The base class allows the user to pass in a function that is used to determine if the
active stage should be provided items. Derived provider classes should override the xxxInternal
methods to provide items.
Implements
Methods
Name | Description | |
---|---|---|
constructor(_providerId: string, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean): BaseUiItemsProvider | ||
onUnregister(): void | Function called when the provider is unregistered via ItemsManager.unregister to allow provider to do cleanup. |
|
provideBackstageItems(): BackstageItem[] | Backstage items are not stage specific so no callback is used | |
provideStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): CommonStatusBarItem[] | UiItemsManager calls following method to augment base statusbar for stages that allow it. | |
provideStatusBarItemsInternal(_stageId: string, _stageUsage: string, _stageAppData?: any): CommonStatusBarItem[] | ||
provideToolbarButtonItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): CommonToolbarItem[] | UiItemsManager calls following method to get items to populate specific toolbars | |
provideToolbarButtonItemsInternal(_stageId: string, _stageUsage: string, _toolbarUsage: ToolbarUsage, _toolbarOrientation: ToolbarOrientation, _stageAppData?: any): CommonToolbarItem[] | ||
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, _zoneLocation?: AbstractZoneLocation, stageAppData?: any): undefined | UiItemsManager calls following method to augment Widget lists. | |
provideWidgetsInternal(_stageId: string, _stageUsage: string, _location: StagePanelLocation, _section?: StagePanelSection, _zoneLocation?: AbstractZoneLocation, _stageAppData?: any): AbstractWidgetProps[] | ||
unregister(): void |
Properties
Name | Type | Description | |
---|---|---|---|
_providerId Protected | string | ||
id Accessor ReadOnly | string | id of provider | |
isSupportedStage | undefined | (stageId: string, stageUsage: string, stageAppData?: any, provider?: UiItemsProvider) => boolean |
Defined in
Last Updated: 20 June, 2023