AbstractStatusBarLabelItem Interface
Deprecated in 3.6. Use StatusBarLabelItem instead.
Describes the data needed to insert a label item with an optional icon into the status bar.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
icon Readonly | string | ConditionalStringValue | Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id. | |
label Readonly | string | ConditionalStringValue | Label. | |
labelSide Readonly | undefined | StatusBarLabelSide | Defines which side of icon to display label if icon is defined. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
applicationData | undefined | any | AbstractStatusBarItem | can be used by application to store miscellaneous data. |
badgeType Readonly | undefined | BadgeType | AbstractStatusBarItem | Describes badge. |
id Readonly | string | AbstractStatusBarItem | Required unique id of the item. |
internalData Readonly | undefined | Map<string, any> | AbstractStatusBarItem | optional data to used by item implementor. |
isDisabled Readonly | boolean | ConditionalBooleanValue | AbstractStatusBarItem | Describes if the item is enabled or disabled. |
isHidden Readonly | boolean | ConditionalBooleanValue | AbstractStatusBarItem | Describes if the item is visible or hidden. |
itemPriority Readonly | number | AbstractStatusBarItem | Priority within a section (recommend using values 1 through 100). |
providerId Readonly | undefined | string | AbstractStatusBarItem | id of UiItemsProvider |
section Readonly | StatusBarSection | AbstractStatusBarItem | status bar section |
Defined in
Last Updated: 20 June, 2023