AbstractStatusBarItem Interface
Deprecated in 3.6. Use CommonStatusBarItem instead.
Describes the data needed to insert a button into the status bar.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
applicationData | undefined | any | can be used by application to store miscellaneous data. | |
badgeType Readonly | undefined | BadgeType | Describes badge. | |
id Readonly | string | Required unique id of the item. | |
internalData Readonly | undefined | Map<string, any> | optional data to used by item implementor. | |
isDisabled Readonly | boolean | ConditionalBooleanValue | Describes if the item is enabled or disabled. | |
isHidden Readonly | boolean | ConditionalBooleanValue | Describes if the item is visible or hidden. | |
itemPriority Readonly | number | Priority within a section (recommend using values 1 through 100). | |
section Readonly | StatusBarSection | status bar section |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
providerId Readonly | undefined | string | ProvidedItem | id of UiItemsProvider |
Defined in
Last Updated: 20 June, 2023