PropertyDescriptionHelper Class
Helper class that builds property descriptions for specific PropertyEditors and processes descriptions.
Methods
Name | Description | |
---|---|---|
constructor(): PropertyDescriptionHelper | ||
buildCheckboxDescription(name: string, label: string, additionalParams: BasePropertyEditorParams[] = []): PropertyDescription Static | Builds a boolean description for a tool settings or dialog property that will display a checkbox control. | |
buildColorPickerDescription(name: string, label: string, colorValues: number[], numColumns: number, additionalParams: BasePropertyEditorParams[] = []): PropertyDescription Static | Builds a number description for a tool settings or dialog property that will display a "color-picker" control. | |
buildEnumPicklistEditorDescription(name: string, label: string, choices: EnumerationChoice[] | Promise<EnumerationChoice[]>, additionalParams: BasePropertyEditorParams[] = []): PropertyDescription Static | Builds an enum description | |
buildImageCheckBoxDescription(name: string, label: string, imageOff: string, imageOn: string, additionalParams: BasePropertyEditorParams[] = []): PropertyDescription Static | Builds a boolean description for a tool settings or dialog property that will display a "image-check-box" control. | |
buildLockPropertyDescription(name: string, additionalParams: BasePropertyEditorParams[] = []): PropertyDescription Static | Builds a property description for a tool settings or dialog lock property. |
|
buildNumberEditorDescription(name: string, label: string, overrideParams?: RangeEditorParams, additionalParams: BasePropertyEditorParams[] = []): PropertyDescription Static | Builds an editor that uses NumberInput control | |
buildTextEditorDescription(name: string, label: string, additionalParams: BasePropertyEditorParams[] = []): PropertyDescription Static | Builds a string description | |
buildToggleDescription(name: string, label: string, additionalParams: BasePropertyEditorParams[] = []): PropertyDescription Static | Builds a boolean description for a tool settings or dialog property that will display a "toggle" control. | |
buildWeightPickerDescription(name: string, label: string, additionalParams: BasePropertyEditorParams[] = []): PropertyDescription Static | Builds a number description with a "weight-picker" editor name | |
bumpEnumProperty(description: PropertyDescription, value: string | number): Promise<string | number> Static | Bumps an enum property description value |
Defined in
Last Updated: 20 June, 2023