UiItemsManager Class
Deprecated in 3.6. Use UiItemsManager instead.
Controls registering of UiItemsProviders and calls the provider's methods when populating different parts of the User Interface.
Methods
Name | Description | |
---|---|---|
constructor(): UiItemsManager | ||
getBackstageItems(): BackstageItem[] Static | Called when the application is populating the statusbar so that any registered UiItemsProvider can add status fields | |
getStatusBarItems(stageId: string, stageUsage: string, stageAppData?: any): CommonStatusBarItem[] Static | Called when the application is populating the statusbar so that any registered UiItemsProvider can add status fields | |
getToolbarButtonItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): CommonToolbarItem[] Static | Called when the application is populating a toolbar so that any registered UiItemsProvider can add tool buttons that either either execute | |
getUiItemsProvider(providerId: string): undefined | UiItemsProvider Static | Retrieves a previously loaded UiItemsProvider. | |
getWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, zoneLocation?: AbstractZoneLocation, stageAppData?: any): undefined Static | Called when the application is populating the Stage Panels so that any registered UiItemsProvider can add widgets | |
register(uiProvider: UiItemsProvider, overrides?: UiItemProviderOverrides): void Static | Registers a UiItemsProvider with the UiItemsManager. | |
unregister(uiProviderId: string): void Static | Remove a specific UiItemsProvider from the list of available providers. |
Properties
Name | Type | Description | |
---|---|---|---|
hasRegisteredProviders Accessor StaticReadOnly | boolean | Return true if there is any registered UiProvider. | |
onUiProviderRegisteredEvent StaticReadonly | BeEvent<(ev: UiItemProviderRegisteredEventArgs) => void> | Event raised any time a UiProvider is registered or unregistered. | |
registeredProviderIds Accessor StaticReadOnly | string[] | Return number of registered UiProvider. |
Defined in
Last Updated: 20 June, 2023