LayoutHorizontalSplitProps Interface
Properties for a horizontal layout split When a member is a LayoutFragmentProps, it creates a nested split pane. When a number, it represents an index into a ContentGroup.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
bottom | number | LayoutFragmentProps | Bottom layout fragment properties. | |
minSizeBottom | undefined | number | Minimum size of the bottom fragment. | |
minSizeTop | undefined | number | Minimum size of the top fragment. | |
top | number | LayoutFragmentProps | Top layout fragment properties. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
id | string | LayoutSplitPropsBase | The id used to save the current state of the splitter |
lock | undefined | boolean | LayoutSplitPropsBase | Used to lock splitter into fixed position. |
percentage | number | LayoutSplitPropsBase | The percentage of this layout that should be occupied by the top/left fragment by default |
Defined in
Last Updated: 20 June, 2023