SliderEditorParams Interface
Parameters used to indicate that a Slider should be presented for the property and to specify the values needed by the slider.
Extends
Methods
Name | Description | |
---|---|---|
formatTick(tick: number): string Optional | Format a tick mark value | |
formatTooltip(value: number): string Optional | Format a value for the tooltip | |
getTickCount(): number Optional | Function to get the tick count. | |
getTickValues(): number[] Optional | Function to get the tick values. |
Properties
Name | Type | Description | |
---|---|---|---|
maxIconSpec | undefined | string | Image to show for max. | |
maximum | number | Defines the maximum value. | |
minIconSpec | undefined | string | Image to show for min. | |
minimum | number | Defines the minimum value. | |
mode | undefined | number | The interaction mode. | |
reversed | undefined | boolean | Indicates whether the display of the Slider values is reversed. | |
showMinMax | undefined | boolean | Indicates whether to show min & max values to the left & right of the Slider. | |
showTickLabels | undefined | boolean | Indicates whether to show tick labels under the tick marks. | |
showTicks | undefined | boolean | Indicates whether to show tick marks under the Slider. | |
showTooltip | undefined | boolean | Indicates whether to show tooltip with the value. | |
size | undefined | number | Optionally define the width in pixels. | |
step | undefined | number | Step value. | |
tooltipBelow | undefined | boolean | Indicates whether the tooltip should show below the Slider instead of above. | |
type | Slider |
Defined in
Last Updated: 20 June, 2023