SelectionHandlerProps Interface
Properties for creating a SelectionHandler
instance.
Properties
Name | Type | Description | |
---|---|---|---|
imodel | IModelConnection | iModel connection the selection changes will be associated with. | |
manager | SelectionManager | SelectionManager used to store overall selection. | |
name | string | Name of the selection handler. | |
onSelect | SelectionChangesListener | undefined | Callback function called when selection changes. | |
rulesetId | string | undefined | ID of presentation ruleset used by the component using this handler. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.