RulesetVariablesManager Interface
Presentation ruleset variables' registry.
Methods
Name | Description | |
---|---|---|
getBool(variableId: string): Promise<boolean> | Retrieves boolean variable value. |
|
getId64(variableId: string): Promise<string> | Retrieves Id64String variable value. |
|
getId64s(variableId: string): Promise<string[]> | Retrieves Id64String[] variable value. |
|
getInt(variableId: string): Promise<number> | Retrieves number variable value. |
|
getInts(variableId: string): Promise<number[]> | Retrieves number[] variable value. |
|
getString(variableId: string): Promise<string> | Retrieves string variable value. |
|
setBool(variableId: string, value: boolean): Promise<void> | Sets boolean variable value |
|
setId64(variableId: string, value: string): Promise<void> | Sets Id64String variable value |
|
setId64s(variableId: string, value: string[]): Promise<void> | Sets Id64String[] variable value |
|
setInt(variableId: string, value: number): Promise<void> | Sets number variable value |
|
setInts(variableId: string, value: number[]): Promise<void> | Sets number[] variable value |
|
setString(variableId: string, value: string): Promise<void> | Sets string variable value |
|
unset(variableId: string): Promise<void> | Unsets variable with given id. |
Properties
Name | Type | Description | |
---|---|---|---|
onVariableChanged | BeEvent<(variableId: string, prevValue: VariableValue, currValue: VariableValue) => void> | An event that is raised when variable changes. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.