PresentationManagerProps Interface
Properties used to configure PresentationManager
Properties
Name | Type | Description | |
---|---|---|---|
activeLocale | string | undefined | Sets the active locale to use when localizing presentation-related | |
activeUnitSystem | UnitSystemKey | undefined | Sets the active unit system to use for formatting property values with | Deprecated |
clientId | string | undefined | ID used to identify client that requests data. | |
defaultFormats | FormatsMap | undefined | A map of default unit formats to use for formatting properties that don't have a presentation format | |
requestTimeout | number | undefined | Timeout (in milliseconds) for how long we're going to wait for RPC request to be fulfilled before throwing | |
schemaContextProvider | (imodel: IModelConnection) => SchemaContext | undefined | Callback that provides SchemaContext for supplied IModelConnection. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.