getNodesAndCount Method
Deprecated in 4.5. Use getNodesIterator instead.
Retrieves total nodes count and a single page of nodes.
getNodesAndCount(requestOptions: HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions }): Promise<{ count: number, nodes: Node[] }>
Parameter | Type | Description |
---|---|---|
requestOptions | HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> & ClientDiagnosticsAttribute & { batchSize?: number, maxParallelRequests?: number } & { paging?: PageOptions } |
Returns - Promise<{ count: number, nodes: Node[] }>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.