RepeatableRelationshipStepSpecification Interface
Specification of a single step in RepeatableRelationshipPathSpecification.
@see Repeatable relationship path specification reference documentation page
Extends
Properties
Name | Type | Description | |
---|---|---|---|
count | number | "*" | When a number is specified, the relationship is traversed recursively the specified number of times. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
direction Inherited | "Forward" | "Backward" | RelationshipStepSpecification | This attribute specifies the direction in which the relationship should be followed. |
relationship Inherited | SingleSchemaClassSpecification | RelationshipStepSpecification | This attribute specifies the ECRelationship that should be used to traverse to target class. |
targetClass Inherited | SingleSchemaClassSpecification | undefined | RelationshipStepSpecification | This attribute may be used to specialize the target of the relationship. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.