PropertySortingRule Interface
Rule to configure sorting for certain ECInstances in the hierarchy and/or content. It is possible to configure different sorting for different types of ECInstances.
@see Property sorting rule reference documentation section
Extends
Properties
Name | Type | Description | |
---|---|---|---|
propertyName | string | Specifies name of the property which should be used for sorting. | |
ruleType | "PropertySorting" | Used for serializing to JSON. | |
sortAscending | boolean | undefined | Specifies whether instances should be sorted in ascending order or descending. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
class Inherited | SingleSchemaClassSpecification | undefined | SortingRuleBase | Specifies ECClass whose ECInstances should be sorted. |
condition Inherited | string | undefined | SortingRuleBase | Defines a condition which needs to be met in order for the rule to be used. |
isPolymorphic Inherited | boolean | undefined | SortingRuleBase | Specifies that class attribute defined in this rule should be handled polymorphically. |
onlyIfNotHandled Inherited | boolean | undefined | SortingRuleBase | Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule |
priority Inherited | number | undefined | SortingRuleBase | Defines the order in which rules are handled, higher number means the rule is handled first. |
requiredSchemas Inherited | RequiredSchemaSpecification[] | undefined | SortingRuleBase | A list of ECSchema requirements that need to be met for the rule to be used. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.