DisabledSortingRule Interface

Rule to disable sorting for certain ECInstances in the hierarchy and/or content.

@see Disabled sorting rule reference documentation section

Extends

Properties

Name Type Description
ruleType "DisabledSorting" Used for serializing to JSON.  

Inherited properties

Name Type Inherited from Description
class Inherited SingleSchemaClassSpecification | undefined SortingRuleBase Specifies ECClass whose ECInstances should be sorted.
condition Inherited string | undefined SortingRuleBase Defines a condition which needs to be met in order for the rule to be used.
isPolymorphic Inherited boolean | undefined SortingRuleBase Specifies that class attribute defined in this rule should be handled polymorphically.
onlyIfNotHandled Inherited boolean | undefined SortingRuleBase Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule
priority Inherited number | undefined SortingRuleBase Defines the order in which rules are handled, higher number means the rule is handled first.
requiredSchemas Inherited RequiredSchemaSpecification[] | undefined SortingRuleBase A list of ECSchema requirements that need to be met for the rule to be used.

Defined in

Last Updated: 14 November, 2024