ClassGroup Interface
Base class grouping allows grouping ECInstance nodes by their base class (as opposed to the hierarchy
specifications' groupByClass
attribute, which always groups by direct class).
@see Base class grouping documentation section
Extends
Properties
Name | Type | Description | |
---|---|---|---|
baseClass | SingleSchemaClassSpecification | undefined | Specification of the base ECClass to group by. | |
createGroupForSingleItem | boolean | undefined | Specifies whether a grouping node should be created if there is only one item in that group. | |
specType | "Class" | Used for serializing to JSON. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.