NodeKey.equals Function
Checks if two given node keys are equal, taking their versions into account.
When comparing two keys of the same version, the algorithm uses pathFromRoot array which is the most accurate way of checking equality. However, when version are different, pathFromRoot array may contain different strings even though keys represent the same node. In that case equality is checked using other key attributes, depending on the type of the node (type, label, grouping class, property name, etc.).
equals(lhs: NodeKey, rhs: NodeKey): boolean
Parameter | Type | Description |
---|---|---|
lhs | NodeKey | |
rhs | NodeKey |
Returns - boolean
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.