Omit<T, K> Type
Omit = Pick<T, Exclude<, K>>
Create a type with T
properties excluding properties listed in K
.
Usage example: Omit<SomeType, "exclude_prop1" | "exclude_prop2">
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.