Change Log - presentation-common
4.10.1
Thu Nov 14 2024
Updates
- Fixed enum property values formatting issue, where raw value was used instead of enum's display value.
4.10.0
Wed Nov 13 2024
Minor changes
- All public methods of
PresentationRpcInterface
have been deprecated. Going forward, RPC interfaces should not be called directly. Public wrappers such asPresentationManager
should be used instead.
Updates
- Add extended data for calculated properties
- ContentFormatter does not throw when formatting properties with 'undefined' value
- KeySet: Always store instance key class name in
Schema:Class
format. - Fix failure to deserialize content from JSON for instances with nulls in array property values
4.9.5
Tue Oct 22 2024
Version update only
4.9.4
Wed Oct 09 2024
Version update only
4.9.3
Thu Oct 03 2024
Version update only
4.9.2
Wed Oct 02 2024
Version update only
4.9.1
Wed Sep 25 2024
Updates
- Fix failure to deserialize content from JSON for instances with nulls in array property values
4.9.0
Mon Sep 23 2024
Updates
- Different value type support for calculated properties
- Add extended data for calculated properties
- Make calculated property value optional
- Support schema-based property category overrides
4.8.7
Fri Sep 13 2024
Version update only
4.8.6
Fri Sep 06 2024
Version update only
4.8.5
Wed Aug 28 2024
Version update only
4.8.4
Thu Aug 22 2024
Version update only
4.8.3
Fri Aug 16 2024
Version update only
4.8.2
Thu Aug 15 2024
Version update only
4.8.1
Mon Aug 12 2024
Version update only
4.8.0
Thu Aug 08 2024
Updates
- Add
NestedContentValue.labelDefinition
property which is passed toIContentVisitor.startStruct
. - API promotions
4.7.8
Wed Jul 31 2024
Version update only
4.7.7
Fri Jul 19 2024
Version update only
4.7.6
Fri Jul 12 2024
Version update only
4.7.5
Thu Jul 11 2024
Version update only
4.7.4
Mon Jul 01 2024
Version update only
4.7.3
Thu Jun 27 2024
Version update only
4.7.2
Fri Jun 21 2024
Version update only
4.7.1
Thu Jun 13 2024
Version update only
4.7.0
Wed Jun 12 2024
Version update only
4.6.2
Fri Jun 07 2024
Version update only
4.6.1
Wed May 29 2024
Version update only
4.6.0
Mon May 13 2024
Version update only
4.5.2
Tue Apr 16 2024
Version update only
4.5.1
Wed Apr 03 2024
Version update only
4.5.0
Tue Apr 02 2024
Updates
- Updated
KeySet
to work correctly when class names uses both separators:.
and:
. - Support creating hierarchy level descriptor for hierarchies that use
parent
symbol in their instance filters. - Provide an option to control batch size for
PresentationManager.getElementProperties
multi-elements case. - Introduce 2 new types of
PropertiesField
:ArrayPropertiesField
andStructPropertiesField
. Ensure values of these values can be customized, formatted, localized.
4.4.9
Mon Apr 15 2024
Version update only
4.4.8
Mon Mar 25 2024
Version update only
4.4.7
Fri Mar 15 2024
Version update only
4.4.6
Fri Mar 08 2024
Version update only
4.4.5
Tue Mar 05 2024
Version update only
4.4.4
Fri Mar 01 2024
Version update only
4.4.3
Fri Feb 23 2024
Version update only
4.4.2
Fri Feb 16 2024
Version update only
4.4.1
Fri Feb 16 2024
Updates
- Support creating hierarchy level descriptor for hierarchies that use
parent
symbol in their instance filters.
4.4.0
Mon Feb 12 2024
Updates
- Handle SI and METRIC unit systems as a single unit system. This fixes a problem where temperatures are formatted in Kelvin even though metric was requested.
- Provide an option to control batch size for
PresentationManager.getElementProperties
multi-elements case. - Add formatting for kind of quantity point properties.
- Add support for default formats in
KoqPropertyValueFormatter
.
4.3.5
Mon Mar 25 2024
Version update only
4.3.4
Fri Mar 22 2024
Version update only
4.3.3
Wed Jan 03 2024
Version update only
4.3.2
Thu Dec 14 2023
Version update only
4.3.1
Wed Dec 13 2023
Version update only
4.3.0
Thu Dec 07 2023
Updates
- Handle SI and METRIC unit systems as a single unit system. This fixes a problem where temperatures are formatted in Kelvin even though metric was requested.
- Add formatting for kind of quantity point properties.
- Add support for default formats in
KoqPropertyValueFormatter
.
4.2.4
Mon Nov 20 2023
Version update only
4.2.3
Mon Nov 06 2023
Version update only
4.2.2
Thu Nov 02 2023
Version update only
4.2.1
Tue Oct 24 2023
Version update only
4.2.0
Tue Oct 17 2023
Updates
- Add
Field.matchesDescriptor
andDescriptor.getFieldByDescriptor
to lookup fields by their field descriptor.
4.1.9
Tue Oct 10 2023
Version update only
4.1.8
Fri Oct 06 2023
Version update only
4.1.7
Thu Sep 28 2023
Version update only
4.1.6
Tue Sep 12 2023
Version update only
4.1.5
Fri Sep 08 2023
Version update only
4.1.4
Thu Sep 07 2023
Version update only
4.1.3
Wed Aug 30 2023
Version update only
4.1.2
Wed Aug 23 2023
Version update only
4.1.1
Fri Aug 18 2023
Version update only
4.1.0
Mon Aug 14 2023
Updates
- Upgrade sinon to 15.0.4
- New attributes on calculated properties:
renderer
,editor
,categoryId
- New
createClassCategory
attribute on Id category identifier - With hierarchy level descriptor return the ruleset that was used to create that descriptor.
- Switch to ESLint new flat config system
4.0.7
Thu Aug 10 2023
Version update only
4.0.6
Mon Jul 24 2023
Version update only
4.0.5
Tue Jul 18 2023
Version update only
4.0.4
Wed Jul 12 2023
Version update only
4.0.3
Mon Jul 03 2023
Version update only
4.0.2
Wed Jun 21 2023
Version update only
4.0.1
Wed Jun 21 2023
Version update only
4.0.0
Mon May 22 2023
Updates
- Fixed improper use of
ISchemaLocater
interface - Remove
handleInstancesPolymorphically
fromContentInstancesOfSpecificClassesSpecification
- Update to eslint@8
- Add deprecation attributes to
Ruleset.schema.json
- Promote
PropertyInfo.kindOfQuantity
to@public
- Added new
applyOnNestedContent
attribute on content modifier - Added
Format
lookup inECSchema
for formatting properties withKindOfQuantity
- Added peer dependency
@itwin/ecschema-metadata
- Add
HierarchyRequestOptions.sizeLimit
attribute to support hierarchy level size limiting - Promoted some
@internal
APIs to@public
. - Cleaned up localizable strings
- Promote
LabelDefinition
APIs to@public
. - Added
PropertyFormatter
for formatting property values inContent
- Change RPC requests' timeout handling - instead of repeating 5 times, repeat for a specified amount of time (10 minutes by default)
- Removed unused Update related types
- Added
ContentPropertyValuesFormatter
for content values' formatting on either frontend or backend - Fix
@deprecated
messages
3.8.0
Fri Dec 08 2023
Version update only
3.7.17
Mon Nov 20 2023
Version update only
3.7.16
Mon Oct 16 2023
Version update only
3.7.15
Tue Oct 10 2023
Version update only
3.7.14
Fri Sep 29 2023
Version update only
3.7.13
Tue Aug 08 2023
Version update only
3.7.12
Thu Jul 27 2023
Version update only
3.7.11
Tue Jul 11 2023
Version update only
3.7.10
Wed Jul 05 2023
Version update only
3.7.9
Tue Jun 20 2023
Version update only
3.7.8
Thu Jun 01 2023
Version update only
3.7.7
Wed May 24 2023
Version update only
3.7.6
Mon May 15 2023
Version update only
3.7.5
Thu May 04 2023
Version update only
3.7.4
Tue Apr 25 2023
Version update only
3.7.3
Thu Apr 20 2023
Version update only
3.7.2
Wed Apr 12 2023
Version update only
3.7.1
Mon Apr 03 2023
Version update only
3.7.0
Wed Mar 29 2023
Updates
- Fix
@deprecated
messages
3.6.3
Mon Mar 27 2023
Version update only
3.6.2
Fri Mar 17 2023
Version update only
3.6.1
Fri Feb 24 2023
Version update only
3.6.0
Wed Feb 08 2023
Updates
- API promotions
- Deprecate a number of
{api_name}JSON
interfaces in favor of sibling{api_name}
interface - Take
InstanceFilterDefinition
instead of pure string ECExpression for hierarchy level filter - Allow specifying enum values in presentation rules as strings
- Add APIs to get hierarchy level descriptor
- Introduce unfilterable nodes and hierarchy levels
- React to RPC deprecations.
3.5.6
Fri Feb 24 2023
Version update only
3.5.5
Thu Jan 26 2023
Version update only
3.5.4
Wed Jan 18 2023
Version update only
3.5.3
Fri Jan 13 2023
Version update only
3.5.2
Wed Jan 11 2023
Version update only
3.5.1
Thu Dec 15 2022
Version update only
3.5.0
Wed Dec 07 2022
Updates
- Renamed content descriptor property 'filterExpression' to 'fieldsFilterExpression'
- Added InstanceFilterDefinition
- Remove uses of
__dirname
, which is not available in ESM context. - Add support for old
KeySetJSON
format which used uncompressed IDs.
3.4.7
Wed Nov 30 2022
Version update only
3.4.6
Tue Nov 22 2022
Version update only
3.4.5
Thu Nov 17 2022
Version update only
3.4.4
Thu Nov 10 2022
Version update only
3.4.3
Fri Oct 28 2022
Version update only
3.4.2
Mon Oct 24 2022
Version update only
3.4.1
Mon Oct 17 2022
Version update only
3.4.0
Thu Oct 13 2022
Version update only
3.3.5
Tue Sep 27 2022
Version update only
3.3.4
Thu Sep 08 2022
Version update only
3.3.3
Tue Sep 06 2022
Version update only
3.3.2
Thu Sep 01 2022
Version update only
3.3.1
Fri Aug 26 2022
Version update only
3.3.0
Thu Aug 18 2022
Updates
- upgrade mocha to version 10.0.0
- Add target info to NavigationPropertyInfo
PresentationRpcInterface
: Enable response compression for certain operations.
3.2.9
Fri Aug 26 2022
Version update only
3.2.8
Tue Aug 09 2022
Version update only
3.2.7
Mon Aug 01 2022
Version update only
3.2.6
Fri Jul 15 2022
Version update only
3.2.5
Wed Jul 13 2022
Version update only
3.2.4
Tue Jun 21 2022
Version update only
3.2.3
Fri Jun 17 2022
Version update only
3.2.2
Fri Jun 10 2022
Updates
- Add support for nth level element selection scopes
3.2.1
Tue Jun 07 2022
Version update only
3.2.0
Fri May 20 2022
Updates
- Deprecated StyleOverrideRule, ImageIdOverrideRule, CheckboxRule and LabelOverrideRule
- Documentation updates.
3.1.3
Fri Apr 15 2022
Version update only
3.1.2
Wed Apr 06 2022
Version update only
3.1.1
Thu Mar 31 2022
Version update only
3.1.0
Tue Mar 29 2022
Updates
- Deprecate
PropertyGroupingValue
,PropertyGroup.groupingValue
andPropertyGroup.sortingValue
.
3.0.3
Fri Mar 25 2022
Version update only
3.0.2
Thu Mar 10 2022
Version update only
3.0.1
Thu Feb 24 2022
Version update only
3.0.0
Mon Jan 24 2022
Updates
- Removed deprecated rules for iModel.js 3.0.
- Upgrade target to ES2019 and deliver both a CommonJs and ESModule version of package
- rename contextId -> iTwinId
- Added 'BaseNodeKey.version' property and 'NodeKey.equals' function to compare keys taking their versions into account.
- rename to @itwin/presentation-common
- Added
excludedClasses
attribute toContentInstancesOfSpecificClassesSpecification
andInstanceNodesOfSpecificClassesSpecification
specifications. - Added 'onlyIfNotHandled' property support to all content rule specifications
- Update
SelectClassInfo.pathFromInputToSelectClass
type definition to match reality - the relationship may not always be set. - Clean up deprecated APIs
- Added API to get properties of all elements.
- Added
getContentSources
RPC to retrieve information about where content for specific types of elements comes from. - Fixed processing of merged content values under nested content field.
- Remove ability to get multiple element properties over RPC.
- Add
getContentInstanceKeys
RPC to efficiently get content instance keys. - Remove
priority
attribute from presentation request options type. - Optimize
KeySetJSON
size by compressing instance IDs. - Remove
PresentationRpcInterface.loadHierarchy
. - The
condition
attribute should be defined on bothChildNodeRule
andRootNodeRule
. - Added
ignoreCategories
parameter increateFieldHierarchies
function for adding all of the nested properties to parent field's child fields without considering categories. - Removed
PresentationUnitSystem
in favor ofUnitSystemKey
from@itwin/core-quantity
. - remove ClientRequestContext.current
2.19.28
Wed Jan 12 2022
Version update only
2.19.27
Wed Jan 05 2022
Version update only
2.19.26
Wed Dec 08 2021
Version update only
2.19.25
Fri Dec 03 2021
Version update only
2.19.24
Mon Nov 29 2021
Version update only
2.19.23
Mon Nov 22 2021
Version update only
2.19.22
Tue Nov 16 2021
Version update only
2.19.21
Wed Nov 10 2021
Version update only
2.19.20
Fri Oct 29 2021
Version update only
2.19.19
Mon Oct 25 2021
Version update only
2.19.18
Thu Oct 21 2021
Version update only
2.19.17
Thu Oct 14 2021
Version update only
2.19.16
Mon Oct 11 2021
Version update only
2.19.15
Fri Oct 08 2021
Version update only
2.19.14
Fri Oct 01 2021
Version update only
2.19.13
Tue Sep 21 2021
Version update only
2.19.12
Wed Sep 15 2021
Updates
- Fixed processing of merged content values under nested content field.
2.19.11
Thu Sep 09 2021
Version update only
2.19.10
Wed Sep 08 2021
Version update only
2.19.9
Wed Aug 25 2021
Version update only
2.19.8
Mon Aug 23 2021
Version update only
2.19.7
Fri Aug 20 2021
Version update only
2.19.6
Tue Aug 17 2021
Version update only
2.19.5
Fri Aug 13 2021
Version update only
2.19.4
Thu Aug 12 2021
Version update only
2.19.3
Wed Aug 04 2021
Version update only
2.19.2
Tue Aug 03 2021
Version update only
2.19.1
Thu Jul 29 2021
Version update only
2.19.0
Mon Jul 26 2021
Updates
- Stop delivering pseudo-localized strings
- Provide more information on removed nodes in hierarchy comparison results.
- Added conmpressed interfaces for
DescriptorJSON
and ways to handle them. - Add
RelatedPropertiesSpecification.skipIfDuplicate
attribute - Add a way to display related properties without a special related class category
2.18.4
Tue Aug 10 2021
Version update only
2.18.3
Wed Jul 28 2021
Version update only
2.18.2
Mon Jul 26 2021
Version update only
2.18.1
Fri Jul 16 2021
Version update only
2.18.0
Fri Jul 09 2021
Updates
- Promote
PresentationUnitSystem
to @beta - Expose helper APIs to traverse presentation content.
2.17.3
Mon Jul 26 2021
Version update only
2.17.2
Thu Jul 08 2021
Version update only
2.17.1
Fri Jul 02 2021
Version update only
2.17.0
Mon Jun 28 2021
Updates
- Added ability to associate content items with given input keys.
- Added
relationshipMeaning
property toNestedContentField
- Send
Id64[]
ruleset variables asCompressedId64Set
- Introduce
Ruleset.version
attribute.
2.16.10
Thu Jul 22 2021
Version update only
2.16.9
Tue Jul 06 2021
Version update only
2.16.8
Fri Jul 02 2021
Version update only
2.16.7
Mon Jun 28 2021
Version update only
2.16.6
Mon Jun 28 2021
Version update only
2.16.5
Fri Jun 25 2021
Version update only
2.16.4
Wed Jun 23 2021
Version update only
2.16.3
Wed Jun 16 2021
Version update only
2.16.2
Thu Jun 03 2021
Version update only
2.16.1
Thu May 27 2021
Version update only
2.16.0
Mon May 24 2021
Updates
- Add
requiredSchemas
attribute toRuleset
- Add
PropertyCategorySpecification.parentId
attribute` to support custom categories nesting. - Added
diagnostics
attribute to all presentation requests' props. - Call given diagnostics handler with diagnostics data whenever response has any.
- Add
propertySource
attribute toInstanceLabelOverridePropertyValueSpecification
to allow picking property from a related instance. - Add a new
InstanceLabelOverrideRelatedInstanceLabelSpecification
to allow picking label of a related instance. - Release tags' review
- Introduce
requiredSchemas
attribute for presentation rules - Add support for custom property category renderers.
2.15.6
Wed May 26 2021
Version update only
2.15.5
Thu May 20 2021
Version update only
2.15.4
Tue May 18 2021
Version update only
2.15.3
Mon May 17 2021
Version update only
2.15.2
Wed May 12 2021
Version update only
2.15.1
Wed May 05 2021
Version update only
2.15.0
Fri Apr 30 2021
Updates
- Change
Field
type guards to return boolean - Added new HierarchyUpdateRecord type
- Disable hierarchy preloading
2.14.4
Thu Apr 22 2021
Version update only
2.14.3
Thu Apr 15 2021
Version update only
2.14.2
Thu Apr 08 2021
Version update only
2.14.1
Mon Apr 05 2021
Version update only
2.14.0
Fri Apr 02 2021
Updates
- Added 'updateHierarchyState' to PresentationIpcInterface
- Added PresentationIpcInterface
- Added an
extendedType
attribute toPropertyInfo
interface.
2.13.0
Tue Mar 09 2021
Updates
- Added HierarchyCompareInfo object that describes hierarchy changes and next step from which comparison should be continued.
- Updated to use TypeScript 4.1
- begin rename project from iModel.js to iTwin.js
2.12.3
Mon Mar 08 2021
Version update only
2.12.2
Wed Mar 03 2021
Version update only
2.12.1
Tue Feb 23 2021
Version update only
2.12.0
Thu Feb 18 2021
Updates
- Add iModel key to UpdateInfo object.
2.11.2
Wed Feb 17 2021
Version update only
2.11.1
Thu Feb 04 2021
Version update only
2.11.0
Thu Jan 28 2021
Updates
- Include all properties into properties field descriptor to make descriptor match any field that has at least one of those properties
- Updated class names in
KeySet
to be case-insensitive - Added 'activeFormat' property on 'KindOfQuantityInfo' interface.
- Add class information to navigation properties
- Repeat RPC requests when unknown failures happen
2.10.3
Fri Jan 08 2021
Version update only
2.10.2
Fri Jan 08 2021
Version update only
2.10.1
Mon Dec 21 2020
Version update only
2.10.0
Fri Dec 18 2020
Updates
- Include actual primary class ids for nested content fields
- Add support for custom property value renderers
2.9.9
Sun Dec 13 2020
Version update only
2.9.8
Thu Dec 10 2020
Version update only
2.9.7
Wed Dec 09 2020
Version update only
2.9.6
Mon Dec 07 2020
Version update only
2.9.5
Fri Dec 04 2020
Updates
- Repeat RPC requests when unknown failures happen
2.9.4
Wed Dec 02 2020
Updates
- Include actual primary class ids for nested content fields
2.9.3
Mon Nov 23 2020
Version update only
2.9.2
Mon Nov 23 2020
Version update only
2.9.1
Thu Nov 19 2020
Version update only
2.9.0
Wed Nov 18 2020
Updates
- Add
handlePropertiesPolymorphically
attribute toContentInstancesOfSpecificClasses
specification. - Support getting distinct values for x-to-many related properties
2.8.1
Mon Nov 02 2020
Version update only
2.8.0
Fri Oct 23 2020
Updates
- Add diagnostics-related types
- Add
KeySet.some
method - Do not hide grouping nodes when
hideNodesInHierarchy
is specified in hierarchy specification - Do not duplicate nodes when traversing from node that merges multiple instances from the 'many' side of relationship
- Add support for specifying "*" and property overrides in
RelatedPropertiesSpecification.properties
- Ruleset creation fails for (0, 0) 2D point
2.7.6
Wed Nov 11 2020
Version update only
2.7.5
Fri Oct 23 2020
Version update only
2.7.4
Mon Oct 19 2020
Version update only
2.7.3
Wed Oct 14 2020
Version update only
2.7.2
Tue Oct 13 2020
Version update only
2.7.1
Thu Oct 08 2020
Updates
- Ruleset creation fails for (0, 0) 2D point
2.7.0
Fri Oct 02 2020
Updates
- Added a new
DefaultPropertyCategoryOverride
rule - Separate polymorphism of relationship and target class
- Allow requesting distinct content values with
DescriptorOverrides
rather than descriptor itself - Changes to
DescriptorOverrides
: deprecatedsortingFieldName
andsortDirection
in favor ofsorting
attribute, deprecatedhiddenFieldNames
in favor offieldsSelector
. The latter now also allows exclusively including fields. - Made some fields of
Descriptor
andDescriptorSource
readonly. They were never intended to be changed, so now we make that clear.
2.6.5
Sat Sep 26 2020
Version update only
2.6.4
Tue Sep 22 2020
Version update only
2.6.3
Mon Sep 21 2020
Version update only
2.6.2
Mon Sep 21 2020
Version update only
2.6.1
Fri Sep 18 2020
Version update only
2.6.0
Thu Sep 17 2020
Updates
- Moved ESLint configuration to a plugin
2.5.5
Wed Sep 02 2020
Version update only
2.5.4
Fri Aug 28 2020
Version update only
2.5.3
Wed Aug 26 2020
Version update only
2.5.2
Tue Aug 25 2020
Version update only
2.5.1
Mon Aug 24 2020
Version update only
2.5.0
Thu Aug 20 2020
Updates
- Add ability to compare hierarchies based on ruleset variables.
- Made it clear that property grouping nodes might be grouping by multiple raw values.
- Switch to ESLint
2.4.2
Fri Aug 14 2020
Version update only
2.4.1
Fri Aug 07 2020
Version update only
2.4.0
Tue Jul 28 2020
Updates
- Add
suppressSimilarAncestorsCheck
hierarchy specifications attribute. - Add RPC methods that enforce maximum page size, deprecate the old ones.
2.3.3
Thu Jul 23 2020
Version update only
2.3.2
Tue Jul 14 2020
Version update only
2.3.1
Mon Jul 13 2020
Version update only
2.3.0
Fri Jul 10 2020
Updates
- geometry clip containment
- Add ability to request distinct values in pages using field descriptors
- Deprecate
LoggingNamespaces
enum in favor of package-specific enums. - Add support for nested property categories
2.2.1
Tue Jul 07 2020
Version update only
2.2.0
Fri Jun 19 2020
Version update only
2.1.0
Thu May 28 2020
Updates
- Fix assets not being found on backend when webpacked
2.0.0
Wed May 06 2020
Updates
- Clean up deprecated APIs
- Use label definitions instead of plain string in Nodes and Content Items
- Move some @beta APIs to @public
- Added doNotHideOtherPropertiesOnDisplayOverride flag which controls display override behavior for hiding other properties
- Make sure localization files are included in the package
- Fix release tags of various JSON types
- Separate tests from source
- Add ability to set active units system for property values formatting
- Add RPC interface for comparing hierarchies
- Upgrade to Rush 5.23.2
- Remove support for the iModel.js module system by no longer delivering modules.
1.14.1
Wed Apr 22 2020
Updates
- Documentation
1.14.0
Tue Mar 31 2020
Version update only
1.13.0
Wed Mar 04 2020
Version update only
1.12.0
Wed Feb 12 2020
Updates
- Fix broken links
- Make
KeySetJSON
and related types public - Add multi-step relationship path's support in presentation rules.
- Implement multi-step relationship paths support for find similar ruleset
1.11.0
Wed Jan 22 2020
Updates
- Added LabelDefinition and changed Node label property type to LabelDefinition
- Include missing assets directory into package
- Rename
ContentInstancesOfSpecificClassesSpecification.arePolymorphic
tohandleInstancesPolymorphically
to remove ambiguity - Upgrade to TypeScript 3.7.2.
1.10.0
Tue Jan 07 2020
Version update only
1.9.0
Tue Dec 10 2019
Updates
- Fix double quotes not being properly escaped when creating 'find similar' ruleset.
- Add support for multi-ECInstance nodes
- Add a way to group same-label ECInstance nodes at post-processing stage
- Add
NestedContentField.getFieldByName
- Update sinon version.
1.8.0
Fri Nov 22 2019
Updates
- Add property overrides' rule
- Deprecate
PropertiesDisplaySpecification
in favor ofPropertyOverrides
- Deprecate
PropertyEditorsSpecification
in favor ofPropertyOverrides
1.7.0
Fri Nov 01 2019
Version update only
1.6.0
Wed Oct 09 2019
Version update only
1.5.0
Mon Sep 30 2019
Updates
- Add
PresentationStatus.Canceled
member - Add ability to force-load all hierarchy with the given imodel and ruleset
- Added autoExpand property to RelatedPropertiesSpecification and NestedContentField
- Add module descriptions
- Added Ruleset and Ruleset variables to request options to support stateless presentation backend
- Store navigation property classes separate from related property paths
- Upgrade to TypeScript 3.6.2
1.4.0
Tue Sep 10 2019
Updates
- Escape double quotes when creating intance filter for 'find similar' ruleset
- Add NodeArtifacts presentation rule
- Add
hideExpression
attribute to node specifications
1.3.0
Tue Aug 13 2019
Updates
- Add special handling for double values when creating 'similar instances' presentantation ruleset
- Add special handling for point values when creating 'similar instances' presentation ruleset
- Add special handling for DateTime values when creating 'similar instances' presentation ruleset
1.2.0
Wed Jul 24 2019
Version update only
1.1.0
Mon Jul 01 2019
Updates
- Reorganize docs script output
- Add functions
KeySet.forEach
andKeySet.forEachBatch
- Downgrade json-schema-faker dependency to version
0.5.0-rc16
asrc17
causes some tests to crash - Add "String" value specification for
InstanceLabelOverride
rule - Update to TypeScript 3.5
1.0.0
Mon Jun 03 2019
Updates
- RPC system now accepts only basic values (primitives, "interface" objects, and binary).
- Add optional predicate parameter to
KeySet.add
to filter added keys - Add a new presentation rule
ExtendedDataRule
for injecting custom data into presentation objects. - Refactor InstanceLabelOverride rule for more flexibility
- Added handling for timeouted backend responses with request repeating
- Add release tags
- Cleanup API
- Refactor RPC interface to use pure JSON objects
- Fix content descriptor deserialization
0.191.0
Mon May 13 2019
Updates
- Adds parameter for api-extractor to validate missing release tags
- Fix broken links
- Put sourcemap in npm package.
- Fix creating a KeySet from EntityProps which have a
type
property - Fix marshaling class instances through RPC by removing use of Readonly
- Add APIs to retrieve instance labels
- Changed
PresentationRpcInterface.computeSelection
to takeId64String[]
instead ofEntityProps[]
- Allow sending content descriptor overrides instead of descriptor when requesting content. This allows to competely avoid a descriptor request when content customization requirements are the same for all kinds of content
- Upgrade TypeDoc dependency to 0.14.2
0.190.0
Thu Mar 14 2019
Updates
- Documentation fixes
- Fix test scripts for unix systems
0.189.0
Wed Mar 06 2019
Updates
- Changes package.json to include api-extractor and adds api-extractor.json
- Added RpcResponse and PresentationRpcResponse interfaces and changed PresentationRpcInterface to return PresentationRpcResponses instead of raw values.
- Use new buildIModelJsBuild script
- Remove unneeded typedoc plugin dependency
- Create RulesetFactory API for creating presentation rulesets targeted towards specific cases, like 'find similar', etc.
- Save BUILD_SEMVER to globally accessible map
- Change
RulesetsFactory.createSimilarInstancesRuleset
return type from aRuleset
to{ ruleset: Ruleset, description: string }
- Fix RPC requests handler to re-request data if frontend got out-of-sync while syncing with the backed.
- Add selection scopes -related RPC handlers
- RPC Interface changes to optimize getting first page of nodes/content
- Expose node key type guards through index
- Upgrade to TypeScript 3.2.2
0.188.0
Wed Jan 16 2019
Version update only
0.187.0
Tue Jan 15 2019
Version update only
0.186.0
Mon Jan 14 2019
Version update only
0.185.0
Fri Jan 11 2019
Updates
- Introduce
groupedInstancesCount
property for grouping node keys - Add
KeySet.instanceKeysCount
andKeySet.nodeKeysCount
which are faster versions ofKeySet.instanceKeys.size
andKeySet.nodeKeys.size
- Add helper functions to identify type of node key
- Add
getInstancesCount
function to calculate total number of instances included in aKeySet
0.184.0
Thu Jan 10 2019
Version update only
0.183.0
Mon Jan 07 2019
Version update only
0.182.0
Mon Jan 07 2019
Version update only
0.181.0
Fri Jan 04 2019
Version update only
0.180.0
Wed Jan 02 2019
Version update only
0.179.0
Wed Dec 19 2018
Updates
- Invert
isSelectable
property toisSelectionDisabled
so in the most common case (selectable = true) we don't have to send the value
0.178.0
Thu Dec 13 2018
Version update only
0.177.0
Wed Dec 12 2018
Version update only
0.176.0
Mon Dec 10 2018
Updates
- React to signature change for RpcInterface.forward
0.175.0
Mon Dec 10 2018
Version update only
0.174.0
Mon Dec 10 2018
Updates
- Remove unused dependencies, add
build:watch
script
0.173.0
Thu Dec 06 2018
Version update only
0.172.0
Tue Dec 04 2018
Updates
- Changed index file name to match package name, eliminate subdirectory index files, decrease usage of default exports, change imports to use other packages' index file.
0.171.0
Mon Dec 03 2018
Version update only
0.170.0
Mon Nov 26 2018
Version update only
0.169.0
Tue Nov 20 2018
Version update only
0.168.0
Sat Nov 17 2018
Version update only
0.167.0
Fri Nov 16 2018
Version update only
0.166.0
Mon Nov 12 2018
Version update only
0.165.0
Mon Nov 12 2018
Updates
- Add KeySet.hasAll and KeySet.hasAny to check set contents
- Add KeySet.guid to check if keys have changed
0.164.0
Thu Nov 08 2018
Updates
- Updated to TypeScript 3.1
0.163.0
Wed Oct 31 2018
Version update only
0.162.0
Wed Oct 24 2018
Updates
- Fix value deserialization when values were not set (null vs undefined)
- Hide internal types from declarations and docs
0.161.0
Fri Oct 19 2018
Version update only
0.160.0
Wed Oct 17 2018
Version update only
0.159.0
Tue Oct 16 2018
Version update only
0.158.0
Mon Oct 15 2018
Version update only
0.157.0
Sun Oct 14 2018
Updates
- Fixing scripts for linux
0.156.0
Fri Oct 12 2018
Updates
- Initial release
Last Updated: 14 November, 2024