RulesetVariablesManager Interface
Presentation ruleset variables registry.
Methods
Name | Description | |
---|---|---|
getBool(variableId: string): boolean | Retrieves boolean variable value. |
|
getId64(variableId: string): string | Retrieves Id64String variable value. |
|
getId64s(variableId: string): string[] | Retrieves Id64String[] variable value. |
|
getInt(variableId: string): number | Retrieves number variable value. |
|
getInts(variableId: string): number[] | Retrieves number[] variable value. |
|
getString(variableId: string): string | Retrieves string variable value. |
|
getValue(variableId: string, type: VariableValueTypes): VariableValue | Gets a value of the specified type and ID | |
setBool(variableId: string, value: boolean): void | Sets boolean variable value |
|
setId64(variableId: string, value: string): void | Sets Id64String variable value |
|
setId64s(variableId: string, value: string[]): void | Sets Id64String[] variable value |
|
setInt(variableId: string, value: number): void | Sets number variable value |
|
setInts(variableId: string, value: number[]): void | Sets number[] variable value |
|
setString(variableId: string, value: string): void | Sets string variable value |
|
setValue(variableId: string, type: VariableValueTypes, value: VariableValue): void | Sets a value of the specified type | |
unset(variableId: string): void | Unsets variable with given id. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.