computeSelection Method
Overloads | |
---|---|
computeSelection(requestOptions) | |
computeSelection(requestOptions) | Deprecated |
computeSelection(requestOptions)
Computes selection based on provided element IDs and selection scope.
computeSelection(requestOptions: ComputeSelectionRequestOptions<IModelDb> & BackendDiagnosticsAttribute): Promise<KeySet>
Parameter | Type | Description |
---|---|---|
requestOptions | ComputeSelectionRequestOptions<IModelDb> & BackendDiagnosticsAttribute |
Returns - Promise<KeySet>
computeSelection(requestOptions)
Deprecated in 3.x. Use overload with ComputeSelectionRequestOptions
parameter.
Computes selection set based on provided selection scope.
computeSelection(requestOptions: SelectionScopeRequestOptions<IModelDb> & { ids: string[], scopeId: string } & BackendDiagnosticsAttribute): Promise<KeySet>
Parameter | Type | Description |
---|---|---|
requestOptions | SelectionScopeRequestOptions<IModelDb> & { ids: string[], scopeId: string } & BackendDiagnosticsAttribute |
Returns - Promise<KeySet>
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.