Change Log - presentation-backend
4.10.1
Thu Nov 14 2024
Version update only
4.10.0
Wed Nov 13 2024
Updates
- Update snapshots for tests
4.9.5
Tue Oct 22 2024
Version update only
4.9.4
Wed Oct 09 2024
Version update only
4.9.3
Thu Oct 03 2024
Version update only
4.9.2
Wed Oct 02 2024
Version update only
4.9.1
Wed Sep 25 2024
Version update only
4.9.0
Mon Sep 23 2024
Updates
- Update snapshots for tests
- Enhanced the "single element" overload of
PresentationManager.getElementProperties
to accept a custom content parser.
4.8.7
Fri Sep 13 2024
Version update only
4.8.6
Fri Sep 06 2024
Version update only
4.8.5
Wed Aug 28 2024
Version update only
4.8.4
Thu Aug 22 2024
Version update only
4.8.3
Fri Aug 16 2024
Version update only
4.8.2
Thu Aug 15 2024
Version update only
4.8.1
Mon Aug 12 2024
Version update only
4.8.0
Thu Aug 08 2024
Updates
- API promotions and cleanup of some
@alpha
ones. RulesetEmbedder
: Add ability to specify parentbis.Subject
for the presentation rulesets'Subject
.
4.7.8
Wed Jul 31 2024
Version update only
4.7.7
Fri Jul 19 2024
Version update only
4.7.6
Fri Jul 12 2024
Version update only
4.7.5
Thu Jul 11 2024
Version update only
4.7.4
Mon Jul 01 2024
Version update only
4.7.3
Thu Jun 27 2024
Version update only
4.7.2
Fri Jun 21 2024
Version update only
4.7.1
Thu Jun 13 2024
Version update only
4.7.0
Wed Jun 12 2024
Version update only
4.6.2
Fri Jun 07 2024
Version update only
4.6.1
Wed May 29 2024
Version update only
4.6.0
Mon May 13 2024
Updates
- Fix
PresentationRpcImpl.getPagedContentSet
returningSuccess
status with empty result when underlyinggetPagedContent
returns an error.
4.5.2
Tue Apr 16 2024
Updates
- Fix
PresentationRpcImpl.getPagedContentSet
returningSuccess
status with empty result when underlyinggetPagedContent
returns an error.
4.5.1
Wed Apr 03 2024
Version update only
4.5.0
Tue Apr 02 2024
Updates
- Only add "descriptor only" flag when requests come through RPC or if input content flags are
undefined
. This effectively removes the flag forgetElementProperties
request (multi-elements case), which improves performance when requesting content set. - Refactor iModel updates' tracking to work without polling. Also, the updates are now always tracked - no additional configuration is needed.
4.4.9
Mon Apr 15 2024
Version update only
4.4.8
Mon Mar 25 2024
Version update only
4.4.7
Fri Mar 15 2024
Version update only
4.4.6
Fri Mar 08 2024
Version update only
4.4.5
Tue Mar 05 2024
Version update only
4.4.4
Fri Mar 01 2024
Version update only
4.4.3
Fri Feb 23 2024
Version update only
4.4.2
Fri Feb 16 2024
Version update only
4.4.1
Fri Feb 16 2024
Version update only
4.4.0
Mon Feb 12 2024
Updates
- Add support for Node 20.
- Fix descriptor, node path and distinct value responses not being localized
- Fixed
getElementProperties
function to pass correct content options when loading properties. - Load built-in rulesets as code rather than separately delivered assets
- Only add "descriptor only" flag when requests come through RPC or if input content flags are
undefined
. This effectively removes the flag forgetElementProperties
request (multi-elements case), which improves performance when requesting content set. - Allow specifying formatting props for multiple unit systems per phenomenon.
- Improve performance of
PresentationManager.getElementProperties
"multi" case by ~100%. Add a way to provide custom content parser. - Add support for default formats when formatting values in TS (when
Presentation
is initialized withschemaContextProvider
). - Refactor iModel updates' tracking to work without polling. Also, the updates are now always tracked - no additional configuration is needed.
4.3.5
Mon Mar 25 2024
Version update only
4.3.4
Fri Mar 22 2024
Version update only
4.3.3
Wed Jan 03 2024
Version update only
4.3.2
Thu Dec 14 2023
Version update only
4.3.1
Wed Dec 13 2023
Version update only
4.3.0
Thu Dec 07 2023
Updates
- Add support for Node 20.
- Fixed
getElementProperties
function to pass correct content options when loading properties. - Load built-in rulesets as code rather than separately delivered assets
- Allow specifying formatting props for multiple unit systems per phenomenon.
- Add support for default formats when formatting values in TS (when
Presentation
is initialized withschemaContextProvider
).
4.2.4
Mon Nov 20 2023
Version update only
4.2.3
Mon Nov 06 2023
Version update only
4.2.2
Thu Nov 02 2023
Version update only
4.2.1
Tue Oct 24 2023
Version update only
4.2.0
Tue Oct 17 2023
Updates
- Fixed Presentation RPC throwing on multiple repeated requests
4.1.9
Tue Oct 10 2023
Version update only
4.1.8
Fri Oct 06 2023
Version update only
4.1.7
Thu Sep 28 2023
Version update only
4.1.6
Tue Sep 12 2023
Version update only
4.1.5
Fri Sep 08 2023
Updates
- Fixed Presentation RPC throwing on multiple repeated requests
4.1.4
Thu Sep 07 2023
Version update only
4.1.3
Wed Aug 30 2023
Version update only
4.1.2
Wed Aug 23 2023
Version update only
4.1.1
Fri Aug 18 2023
Version update only
4.1.0
Mon Aug 14 2023
Updates
- Upgrade sinon to 15.0.4
- Modified supplemental rules to use newer approach on creating categories
- Update supplemental rules to not use unnecessary
class
attribute in content modifier. Update docs. - Fix "Source Element ID" property being assigned a wrong category
- Switch to ESLint new flat config system
4.0.7
Thu Aug 10 2023
Version update only
4.0.6
Mon Jul 24 2023
Version update only
4.0.5
Tue Jul 18 2023
Version update only
4.0.4
Wed Jul 12 2023
Version update only
4.0.3
Mon Jul 03 2023
Version update only
4.0.2
Wed Jun 21 2023
Version update only
4.0.1
Wed Jun 21 2023
Version update only
4.0.0
Mon May 22 2023
Updates
- Update to eslint@8
- Documentation improvements
- Update logging categories under
PresentationBackendNativeLoggerCategory
. - Modified supplemental rules to use new content modifier's attribute
applyOnNestedContent
- Update
BisCore
supplemental rules to include moreRepositoryLink
properties, including from subclasses. - Reduce default backend response timeout from 90 seconds to 5 seconds
- Fixed diagnostics not being included in error responses
- Removed IPC method used to track UI state on the backend
- Added content values formatting to
PresentationManager.getContent
3.8.0
Fri Dec 08 2023
Version update only
3.7.17
Mon Nov 20 2023
Version update only
3.7.16
Mon Oct 16 2023
Version update only
3.7.15
Tue Oct 10 2023
Version update only
3.7.14
Fri Sep 29 2023
Version update only
3.7.13
Tue Aug 08 2023
Version update only
3.7.12
Thu Jul 27 2023
Version update only
3.7.11
Tue Jul 11 2023
Version update only
3.7.10
Wed Jul 05 2023
Version update only
3.7.9
Tue Jun 20 2023
Version update only
3.7.8
Thu Jun 01 2023
Version update only
3.7.7
Wed May 24 2023
Version update only
3.7.6
Mon May 15 2023
Version update only
3.7.5
Thu May 04 2023
Version update only
3.7.4
Tue Apr 25 2023
Version update only
3.7.3
Thu Apr 20 2023
Version update only
3.7.2
Wed Apr 12 2023
Updates
- Fix
BisCore
supplemental rules for relatedbis.ExternalSource
properties
3.7.1
Mon Apr 03 2023
Version update only
3.7.0
Wed Mar 29 2023
Version update only
3.6.3
Mon Mar 27 2023
Version update only
3.6.2
Fri Mar 17 2023
Version update only
3.6.1
Fri Feb 24 2023
Version update only
3.6.0
Wed Feb 08 2023
Updates
- API promotions
- Add APIs to get hierarchy level descriptor
- Introduce unfilterable nodes and hierarchy levels
3.5.6
Fri Feb 24 2023
Version update only
3.5.5
Thu Jan 26 2023
Version update only
3.5.4
Wed Jan 18 2023
Version update only
3.5.3
Fri Jan 13 2023
Version update only
3.5.2
Wed Jan 11 2023
Version update only
3.5.1
Thu Dec 15 2022
Version update only
3.5.0
Wed Dec 07 2022
Updates
- Deprecated PresentationManagerProps.mode property
- Deprecate unused
PresentationAssetsRootConfig.common
. - Fix
PresentationRpcImpl
cancelling requests when it's configured to not use a request timeout at all
3.4.7
Wed Nov 30 2022
Version update only
3.4.6
Tue Nov 22 2022
Version update only
3.4.5
Thu Nov 17 2022
Version update only
3.4.4
Thu Nov 10 2022
Version update only
3.4.3
Fri Oct 28 2022
Version update only
3.4.2
Mon Oct 24 2022
Version update only
3.4.1
Mon Oct 17 2022
Version update only
3.4.0
Thu Oct 13 2022
Updates
- lock down @types/semver to 7.3.10
- Updated Node types declaration to support latest v16
- Fix manager diagnostics reporting being affected by individual request diagnostics options
- Add a way to capture current context so it can be used by diagnostics handler when the request is fulfilled
- Added
PresentationManagerProps.diagnosticsCallback
property for setting up diagnostics reporting. - Remove backend localization
3.3.5
Tue Sep 27 2022
Version update only
3.3.4
Thu Sep 08 2022
Version update only
3.3.3
Tue Sep 06 2022
Version update only
3.3.2
Thu Sep 01 2022
Version update only
3.3.1
Fri Aug 26 2022
Version update only
3.3.0
Thu Aug 18 2022
Updates
- upgrade mocha to version 10.0.0
- cancel presentation request when it is removed from pending list
3.2.9
Fri Aug 26 2022
Version update only
3.2.8
Tue Aug 09 2022
Version update only
3.2.7
Mon Aug 01 2022
Version update only
3.2.6
Fri Jul 15 2022
Version update only
3.2.5
Wed Jul 13 2022
Version update only
3.2.4
Tue Jun 21 2022
Version update only
3.2.3
Fri Jun 17 2022
Version update only
3.2.2
Fri Jun 10 2022
Updates
- Add support for nth level element selection scopes
3.2.1
Tue Jun 07 2022
Version update only
3.2.0
Fri May 20 2022
Updates
- Repository model label calculation fix
- Move schemas preloading logic from PresentationManager to Presentation.
3.1.3
Fri Apr 15 2022
Version update only
3.1.2
Wed Apr 06 2022
Version update only
3.1.1
Thu Mar 31 2022
Version update only
3.1.0
Tue Mar 29 2022
Updates
- Fix RPC requests' memoization causing similar requests to different iModels to be memoized as a single request.
3.0.3
Fri Mar 25 2022
Version update only
3.0.2
Thu Mar 10 2022
Updates
- Fix RPC requests' memoization causing similar requests to different iModels to be memoized as a single request.
3.0.1
Thu Feb 24 2022
Version update only
3.0.0
Mon Jan 24 2022
Updates
- Existing ruleset configurations were updated to no longer use deprecated rule versions for iModel.js 3.0.
- Upgrade target to ES2019
- fix ecsql row format
- rename to @itwin/presentation-backend
- remove ClientRequestContext and its subclasses
- Clean up deprecated APIs
- Added API to get properties of all elements.
- Added
PresentationManager.getContentSources
API to retrieve information about where content for specific types of elements comes from. - Fix class and schema names in RelatedProperties rule for ElementOwnsUniqueAspect relationship.
- Fix Presentation IPC handler not being registered until the first Presentation request is made.
- Enforce valid page options on getElementProperties request when requesting properties of multiple elements.
- Fix for getElementProperties request when requesting all elements of specific classes
- Use async iterator when getting properties of multiple elements.
- Add
getContentInstanceKeys
RPC to efficiently get content instance keys. - Restructure backend's initialization props
- Remove
PresentationManager.loadHierarchy
API. - Fix ruleset variables storing in IPC apps
- Updated
RulesetEmbedder
to allow calling callbacks before and after Model/Element is inserted or updated - Changed uses of
PresentationUnitSystem
toUnitSystemKey
. - Always create unique ruleset id when handling nodes requests
- remove ClientRequestContext.current
- remove requestContext argument from importSchemas
2.19.28
Wed Jan 12 2022
Version update only
2.19.27
Wed Jan 05 2022
Version update only
2.19.26
Wed Dec 08 2021
Version update only
2.19.25
Fri Dec 03 2021
Version update only
2.19.24
Mon Nov 29 2021
Version update only
2.19.23
Mon Nov 22 2021
Version update only
2.19.22
Tue Nov 16 2021
Version update only
2.19.21
Wed Nov 10 2021
Version update only
2.19.20
Fri Oct 29 2021
Version update only
2.19.19
Mon Oct 25 2021
Version update only
2.19.18
Thu Oct 21 2021
Version update only
2.19.17
Thu Oct 14 2021
Version update only
2.19.16
Mon Oct 11 2021
Version update only
2.19.15
Fri Oct 08 2021
Version update only
2.19.14
Fri Oct 01 2021
Version update only
2.19.13
Tue Sep 21 2021
Version update only
2.19.12
Wed Sep 15 2021
Version update only
2.19.11
Thu Sep 09 2021
Version update only
2.19.10
Wed Sep 08 2021
Version update only
2.19.9
Wed Aug 25 2021
Version update only
2.19.8
Mon Aug 23 2021
Version update only
2.19.7
Fri Aug 20 2021
Version update only
2.19.6
Tue Aug 17 2021
Version update only
2.19.5
Fri Aug 13 2021
Version update only
2.19.4
Thu Aug 12 2021
Version update only
2.19.3
Wed Aug 04 2021
Version update only
2.19.2
Tue Aug 03 2021
Version update only
2.19.1
Thu Jul 29 2021
Version update only
2.19.0
Mon Jul 26 2021
Updates
- Set
RelatedPropertiesSpecification.skipIfDuplicate
attribute to all specifications in default BisCore ruleset to allow overriding them.
2.18.4
Tue Aug 10 2021
Version update only
2.18.3
Wed Jul 28 2021
Version update only
2.18.2
Mon Jul 26 2021
Version update only
2.18.1
Fri Jul 16 2021
Version update only
2.18.0
Fri Jul 09 2021
Updates
- Add
PresentationManager.getElementProperties
to get properties for a single element in a simplified way. - Add
PresentationRpcInterface.getElementProperties
and related APIs
2.17.3
Mon Jul 26 2021
Version update only
2.17.2
Thu Jul 08 2021
Version update only
2.17.1
Fri Jul 02 2021
Updates
- Do not initialize UpdatesTracker if IPC host is not available. Fixes a problem of presentation manager trying to use IPC after changes to the iModel are made.
2.17.0
Mon Jun 28 2021
Updates
- Fix previous
RulesetVariable
values not being deserialized when comparing hierarchies - Add ability to unset a ruleset variable value
2.16.10
Thu Jul 22 2021
Version update only
2.16.9
Tue Jul 06 2021
Version update only
2.16.8
Fri Jul 02 2021
Version update only
2.16.7
Mon Jun 28 2021
Version update only
2.16.6
Mon Jun 28 2021
Version update only
2.16.5
Fri Jun 25 2021
Version update only
2.16.4
Wed Jun 23 2021
Version update only
2.16.3
Wed Jun 16 2021
Version update only
2.16.2
Thu Jun 03 2021
Version update only
2.16.1
Thu May 27 2021
Version update only
2.16.0
Mon May 24 2021
Updates
- Expose
ExternalSource -> RepositoryLink
related properties when showingElement
content - Fix invalid
ElementOwnsUniqueAspect
relationship name being specified in BisCore supplemental ruleset. This caused unique aspects not being loaded for physical and spatial location type definition elements. - Add missing related properties specifications for core element types
- Release tags' review
- Add BisCore 1.0.2 requirement for
ExternalSourceAspect
rule - Start showing more
TypeDefinitionElement
properties
2.15.6
Wed May 26 2021
Version update only
2.15.5
Thu May 20 2021
Version update only
2.15.4
Tue May 18 2021
Version update only
2.15.3
Mon May 17 2021
Version update only
2.15.2
Wed May 12 2021
Version update only
2.15.1
Wed May 05 2021
Version update only
2.15.0
Fri Apr 30 2021
Updates
- Disable hierarchy preloading
2.14.4
Thu Apr 22 2021
Version update only
2.14.3
Thu Apr 15 2021
Version update only
2.14.2
Thu Apr 08 2021
Version update only
2.14.1
Mon Apr 05 2021
Version update only
2.14.0
Fri Apr 02 2021
Updates
- Added Ipc method 'updateHierarchyState' to allow storing hierarchy state on backend
- Added Ipc handler to allow setting ruleset variables on backend in IpcApps
- Show
UserLabel
andCodeValue
properties forPhysicalType
andSpatialLocationType
elements
2.13.0
Tue Mar 09 2021
Updates
- Added a way to set default property formatting
- Enforce max result set size for hierarchy compare.
- Updated to use TypeScript 4.1
- begin rename project from iModel.js to iTwin.js
2.12.3
Mon Mar 08 2021
Version update only
2.12.2
Wed Mar 03 2021
Version update only
2.12.1
Tue Feb 23 2021
Version update only
2.12.0
Thu Feb 18 2021
Updates
- Associate update records with iModel key.
2.11.2
Wed Feb 17 2021
Version update only
2.11.1
Thu Feb 04 2021
Version update only
2.11.0
Thu Jan 28 2021
Updates
- Lock react-select to 3.1.0 and @types/react-select to 3.0.26 until we can fi
- Add ability to control content cache size
2.10.3
Fri Jan 08 2021
Version update only
2.10.2
Fri Jan 08 2021
Version update only
2.10.1
Mon Dec 21 2020
Version update only
2.10.0
Fri Dec 18 2020
Updates
- Add
PresentationBackendNativeLoggerCategory.ECPresentation_Localization
for localization-related logs - Allow specifying asset path overrides separately for 'presentation-common' and 'presentation-backend' packages
2.9.9
Sun Dec 13 2020
Version update only
2.9.8
Thu Dec 10 2020
Version update only
2.9.7
Wed Dec 09 2020
Version update only
2.9.6
Mon Dec 07 2020
Version update only
2.9.5
Fri Dec 04 2020
Updates
- Add ability to control content cache size
2.9.4
Wed Dec 02 2020
Version update only
2.9.3
Mon Nov 23 2020
Version update only
2.9.2
Mon Nov 23 2020
Version update only
2.9.1
Thu Nov 19 2020
Version update only
2.9.0
Wed Nov 18 2020
Updates
- Add cache config to PresentationManager props in order to control cache type and directory.
- Support getting distinct values for x-to-many related properties
- Re-export
WithClientRequestContext
interface through the barrel file
2.8.1
Mon Nov 02 2020
Version update only
2.8.0
Fri Oct 23 2020
Updates
- Add ability to get per-request diagnostic logs by specifying
diagnostics
options in RPC request - Allow computing selection of removed elements. Simply ignore ids that are not found.
2.7.6
Wed Nov 11 2020
Version update only
2.7.5
Fri Oct 23 2020
Version update only
2.7.4
Mon Oct 19 2020
Version update only
2.7.3
Wed Oct 14 2020
Version update only
2.7.2
Tue Oct 13 2020
Version update only
2.7.1
Thu Oct 08 2020
Version update only
2.7.0
Fri Oct 02 2020
Updates
- Allow requesting distinct content values with
DescriptorOverrides
rather than descriptor itself
2.6.5
Sat Sep 26 2020
Version update only
2.6.4
Tue Sep 22 2020
Version update only
2.6.3
Mon Sep 21 2020
Version update only
2.6.2
Mon Sep 21 2020
Version update only
2.6.1
Fri Sep 18 2020
Version update only
2.6.0
Thu Sep 17 2020
Updates
- Moved ESLint configuration to a plugin
- Make
PresentationManagerProps.cacheDirectory
@beta
2.5.5
Wed Sep 02 2020
Version update only
2.5.4
Fri Aug 28 2020
Version update only
2.5.3
Wed Aug 26 2020
Version update only
2.5.2
Tue Aug 25 2020
Version update only
2.5.1
Mon Aug 24 2020
Version update only
2.5.0
Thu Aug 20 2020
Updates
- Add ability to compare hierarchies based on ruleset variables.
- Switch to ESLint
2.4.2
Fri Aug 14 2020
Version update only
2.4.1
Fri Aug 07 2020
Version update only
2.4.0
Tue Jul 28 2020
Updates
- Add overloads of
PresentationManager
methods that take a single object with all the parameters.
2.3.3
Thu Jul 23 2020
Version update only
2.3.2
Tue Jul 14 2020
Version update only
2.3.1
Mon Jul 13 2020
Version update only
2.3.0
Fri Jul 10 2020
Updates
- geometry clip containment
- Add ability to request distinct values in pages using field descriptors.
- Expose logger categories similar to how it's done in core
- Log RPC requests and their parameters
2.2.1
Tue Jul 07 2020
Version update only
2.2.0
Fri Jun 19 2020
Version update only
2.1.0
Thu May 28 2020
Updates
- Pass ruleset variables with request options instead of setting them in variables manager.
- Added ability to use single manager for all clients
2.0.0
Wed May 06 2020
Updates
- Clean up deprecated APIs
- Change argument lists to props object
- Move some @beta APIs to @public
- When loading related SpatialLocationType and PhysicalType properties, also load their Aspect properties
- Fix aspect relationship class names in BisCore supplemental ruleset
- Fix presentation backend not finding its assets when webpacked
- Fix assets lookup on electron and add a way to override the path
- Use correct physical element ID when looking for related functional element when calculating functional-assembly and functional-top-assembly scoped selection
- Fix functional scopes for
BisCore.GeometricElement3d
elements - Added ability to control hierarchy cache location
- Log when
PresentationManager
instances are created and disposed - Return related functional element key when computing 3d element selection
- Separate tests from source
- Add ability to set active units system for property values formatting
- Add ability to compare hierarchies created using different rules
- Upgrade to Rush 5.23.2
1.14.1
Wed Apr 22 2020
Version update only
1.14.0
Tue Mar 31 2020
Version update only
1.13.0
Wed Mar 04 2020
Updates
- Fix functional scopes for
BisCore.GeometricElement3d
elements
1.12.0
Wed Feb 12 2020
Updates
- Add new hidden 'functional' selection scopes: 'functional-element', 'functional-assembly', 'functional-top-assembly'
- Update 'functional' hilite rules up to the latest requirements, including recursive lookup both at functional and graphical part of the relationship path
- Ignore invalid IDs when computing element selection instead of failing the whole operation
1.11.0
Wed Jan 22 2020
Updates
- Changed node label type from string to LabelDefinition
- Upgrade to TypeScript 3.7.2.
1.10.0
Tue Jan 07 2020
Version update only
1.9.0
Tue Dec 10 2019
Updates
- Update sinon version.
1.8.0
Fri Nov 22 2019
Updates
- Add BisCore supplemental rules to create 'Source File Information' group for BisCore:Elements
1.7.0
Fri Nov 01 2019
Updates
- Add support for read-only PresentationManager mode
1.6.0
Wed Oct 09 2019
Updates
- Add hilite rules for Functional schema
- Add 'functional' selection scope
1.5.0
Mon Sep 30 2019
Updates
- Fix handling of requests that throw, including canceled requests
- Add ability to force-load all hierarchy with the given imodel and ruleset
- Add module descriptions
- Added Ruleset and Ruleset variables to request options to make presentation backend stateless
- Upgrade to TypeScript 3.6.2
1.4.0
Tue Sep 10 2019
Updates
- Renamed category Miscellaneous to General
- Include related LinkElement properties when creating content for Elements
1.3.0
Tue Aug 13 2019
Version update only
1.2.0
Wed Jul 24 2019
Version update only
1.1.0
Mon Jul 01 2019
Updates
- Reorganize docs script output
- Optionally allow asking PresentationManager to pre-load all ECSchemas on iModel open (see
enableSchemasPreload
prop) - Update to TypeScript 3.5
1.0.0
Mon Jun 03 2019
Updates
- Increased default backend timeout up to 90 seconds.
- Removed backend timeout when it is set to 0.
- Added backend timeout closure when request is completed.
- Timeout clearing moved to 'finally' block
- Added presentation request timing out if it takes longer that predefined periond of time.
- Add release tags
- Cleanup API
- Refactor RPC interface to use pure JSON objects
0.191.0
Mon May 13 2019
Updates
- Adds parameter for api-extractor to validate missing release tags
- Remove requirement that JavaScript classnames match BIS classnames
- Fix broken links
- Fix marshaling class instances through RPC by removing use of Readonly
- Fix content requests for BisCore.Element instances when only the base class name is specified (usual case when selecting elements from the viewport)
- Disable "category" and "model" selection scopes
- Dispose PresentationManager in the same client request context as it was created in.
- Fix
computeSelection
and content requests failing when given a key with invalid BisCore:Element id - Add APIs to retrieve instance labels
- Fixed
PresentationRpcImpl.computeSelection
for "model", "category" and "element" scope to return specific class names instead of "BisCore:Model", "BisCore:Category" or "BisCore:Element" - Allow requesting content with descriptor overrides instead of descriptor. This allows to competely avoid a descriptor request when content customization requirements are the same for all kinds of content
- Do not attempt to handle transient element ids when computing selection based on scope
- Setup a generic context for tracking client requests, and made various related enhancements to logging, usage tracking and authorization.
- Upgrade TypeDoc dependency to 0.14.2
0.190.0
Thu Mar 14 2019
Updates
- Fix test scripts for unix systems
0.189.0
Wed Mar 06 2019
Updates
- Changes package.json to include api-extractor and adds api-extractor.json
- Wrapped PresentationRpcImpl method response values in PresentationRpcInterface object.
- Use new buildIModelJsBuild script
- PresentationManager now converts locale string to lower case when creating request parameters.
- Remove unneeded typedoc plugin dependency
- Add hardcoded implementations for 'element', 'assembly', 'top-assembly', 'category', 'model' selection scopes
- RPC Interface changes to optimize getting first page of nodes/content
- Upgrade to TypeScript 3.2.2
0.188.0
Wed Jan 16 2019
Version update only
0.187.0
Tue Jan 15 2019
Version update only
0.186.0
Mon Jan 14 2019
Version update only
0.185.0
Fri Jan 11 2019
Version update only
0.184.0
Thu Jan 10 2019
Version update only
0.183.0
Mon Jan 07 2019
Version update only
0.182.0
Mon Jan 07 2019
Updates
- Move to Node 10
0.181.0
Fri Jan 04 2019
Updates
- Move to Node 10
0.180.0
Wed Jan 02 2019
Version update only
0.179.0
Wed Dec 19 2018
Updates
- Added RulesetEmbedder to embed and get rules to/from iModelDb
0.178.0
Thu Dec 13 2018
Version update only
0.177.0
Wed Dec 12 2018
Version update only
0.176.0
Mon Dec 10 2018
Version update only
0.175.0
Mon Dec 10 2018
Version update only
0.174.0
Mon Dec 10 2018
Updates
- Remove unused dependencies, add
build:watch
script
0.173.0
Thu Dec 06 2018
Version update only
0.172.0
Tue Dec 04 2018
Version update only
0.171.0
Mon Dec 03 2018
Version update only
0.170.0
Mon Nov 26 2018
Version update only
0.169.0
Tue Nov 20 2018
Version update only
0.168.0
Sat Nov 17 2018
Version update only
0.167.0
Fri Nov 16 2018
Version update only
0.166.0
Mon Nov 12 2018
Version update only
0.165.0
Mon Nov 12 2018
Version update only
0.164.0
Thu Nov 08 2018
Updates
- Updated to TypeScript 3.1
0.163.0
Wed Oct 31 2018
Version update only
0.162.0
Wed Oct 24 2018
Updates
- Fixed reduced test coverage
0.161.0
Fri Oct 19 2018
Version update only
0.160.0
Wed Oct 17 2018
Version update only
0.159.0
Tue Oct 16 2018
Version update only
0.158.0
Mon Oct 15 2018
Version update only
0.157.0
Sun Oct 14 2018
Updates
- Fixing scripts for linux
0.156.0
Fri Oct 12 2018
Updates
- Initial release
Last Updated: 14 November, 2024