placeTemplate2d Method

Place a template from the sourceDb at the specified placement in the target model within the targetDb.

placeTemplate2d(sourceTemplateModelId: string, targetModelId: string, placement: Placement2d): Promise<Map<string, string>>

@note Required References like the DrawingCategory must be remapped before calling this method.

@returns The mapping of sourceElementIds from the template model to the instantiated targetElementIds in the targetDb in case further processing is required.

Parameter Type Description
sourceTemplateModelId string The Id of the template model in the sourceDb
targetModelId string The Id of the target model (must be a subclass of GeometricModel2d) where the cloned component will be inserted.
placement Placement2d The placement for the cloned component.

Returns - Promise<Map<string, string>>

The mapping of sourceElementIds from the template model to the instantiated targetElementIds in the targetDb in case further processing is required.

Defined in

Last Updated: 06 November, 2024