constructor Method
Construct a new TemplateModelCloner
TemplateModelCloner(sourceDb: IModelDb, targetDb: IModelDbsourceDb): TemplateModelCloner
@note The expectation is that the template definitions are within the same iModel where instances will be placed.
Parameter | Type | Description |
---|---|---|
sourceDb | IModelDb | The source IModelDb that contains the templates to clone |
targetDb | IModelDb | Optionally specify the target IModelDb where the cloned template will be inserted. Typically this is left unspecified, and the default is to use the sourceDb as the target |
Returns - TemplateModelCloner
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.