onTransformElement Method
Transform the specified sourceElement into ElementProps for the target iModel.
onTransformElement(sourceElement: Element): ElementProps
@returns ElementProps for the target iModel.
@note A subclass can override this method to provide custom transform behavior.
@note This can be called more than once for an element in arbitrary order, so it should not have side-effects.
Parameter | Type | Description |
---|---|---|
sourceElement | Element | The Element from the source iModel to transform. |
Returns - ElementProps
ElementProps for the target iModel.
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.