determineSyncType MethodStatic

Determines the sync direction "forward" or "reverse" of a given sourceDb and targetDb by looking for the scoping ESA. If the sourceDb's iModelId is found as the identifier of the expected scoping ESA in the targetDb, then it is a forward synchronization. If the targetDb's iModelId is found as the identifier of the expected scoping ESA in the sourceDb, then it is a reverse synchronization.

determineSyncType(sourceDb: IModelDb, targetDb: IModelDb, targetScopeElementId: string): "reverse" | "forward"

@throws if no scoping ESA can be found in either the sourceDb or targetDb which describes a master branch relationship between the two databases.

@returns "forward" or "reverse"

Parameter Type Description
sourceDb IModelDb  
targetDb IModelDb  
targetScopeElementId string  

Returns - "reverse" | "forward"

"forward" or "reverse"

Defined in

Last Updated: 06 November, 2024