onInsertRelationship MethodProtected
Create a new Relationship from the specified RelationshipProps and insert it into the target iModel.
onInsertRelationship(relationshipProps: RelationshipProps): string
@returns The instance Id of the newly inserted relationship.
@note A subclass may override this method to customize insert behavior but should call super.onInsertRelationship
.
Parameter | Type | Description |
---|---|---|
relationshipProps | RelationshipProps |
Returns - string
The instance Id of the newly inserted relationship.
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.