onInsertElement MethodProtected
Create a new Element from the specified ElementProps and insert it into the target iModel.
onInsertElement(elementProps: ElementProps): string
@returns The Id of the newly inserted Element.
@note A subclass may override this method to customize insert behavior but should call super.onInsertElement
.
Parameter | Type | Description |
---|---|---|
elementProps | ElementProps |
Returns - string
The Id of the newly inserted Element.
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.