IModelCloneContext Class
The context for transforming a source Element to a target Element and remapping internal identifiers to the target iModel.
Extends
Methods
Name | Description | |
---|---|---|
findTargetAspectId(sourceAspectId: string): string | Look up a target AspectId from the source AspectId. | |
findTargetEntityId(sourceEntityId: | | | ): | | | | Look up a target EntityReference from a source EntityReference | |
initialize(): Promise<void> | perform necessary initialization to use a clone context, namely caching the reference types in the source's schemas | |
remapElementAspect(aspectSourceId: string, aspectTargetId: string): void | Add a rule that remaps the specified source ElementAspect to the specified target ElementAspect. | |
removeElementAspect(aspectSourceId: string): void | Remove a rule that remaps the specified source ElementAspect |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.